Facing Issues when running sikulixide.2.0.5 on windows server 2012 r2, cannot detect image showing opencv_java430.dll(failed)

Asked by Yesh Biswakarma

I have been using SikuliX on local, but when i try to install and run the script on Windows Server 2012 r2, the script does not detect images.

When I run the script from Sikulix IDE, it runs perfectly.
The script is as follows-
Settings.MouseMoveDelay = 0.0
date = datetime.date.today()
# Open Google Chrome
chrome_path = "C:/Program Files/Google/Chrome/Application/chrome.exe"
# Open the website and login
wait("1677668502535.png", FOREVER) # Here the script stops

Problem arises when the script tries to find an image on the screen, then the scripts stops and following error can be seen on IDE and commandline respectively:
[error] RunTime:loadLib: libopencv_java430.so (failed) probably dependent libs missing
TERMINATING: problem with native library: libopencv_java430.so Exception in thread "main" java.lang.ExceptionInInitializerError

I have tried installing the opencv for java, still the script fails to find the image.
Also setting up opencv, the error changes to Finder$FindInput, and the script stops on the same line as mentioned above.

Following are the steps i have used to install Sikulix.2.0.5.jar on Windows Server 2012 R2:
1. first i have installed jre8 on the system and set the PATH of java bin
2. second, I have downloaded the sikulix.jar file
3. third, I run the script and following issues arises

@Raiman Please help me setup the sikulixide. I have been trying it over days now. I have been able to setup Sikulix IDE and run the script on two different Windows 10 local machines. But I am unable to setup Sikulix IDE on Windows Server 2012 R2. Although I am following the same steps ad instructions given on the website. A;so tried to make opencv ready. but same error arises

Question information

English Edit question
SikuliX Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best RaiMan (raimund-hocke) said :

The OpenCV libs are bundled with the jar and exported to <APPDATA>/Sikulix/SikulixLibs at runtime.
You might check that.
No need to install OpenCV on Windows.

On some Windows versions other needed libs are missing, which seems be the case here.

this might help:

Another option is to use a tool that checks libs for missing deps.
You have to consult the net for that.

Revision history for this message
Yesh Biswakarma (yash6238) said :

Thanks RaiMan, that solved my question.