No module named Do

Asked by hcuthbert

Moving from 1.1.3 to 2.0.5
no other changes have been made:

Version 1.1.3 worked with scripts
Version 2.0.5 throws an error on either new or existing scripts

Exception in thread "Thread-39" Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "C:\Users\.....\AppData\Roaming\Sikulix\Lib\sikuli\", line 6, in <module>
    from Sikuli import *
  File "C:\Users\.....\AppData\Roaming\Sikulix\Lib\sikuli\", line 23, in <module>
    import org.sikuli.script.Do as Do
ImportError: No module named Do

Navigated to error locations: contains:
# Copyright 2010-2014,,
# Released under the MIT License.
# modified RaiMan 2013

from org.sikuli.basics import Debug
from Sikuli import * contains an exert:
# Copyright 2010-2016,,
# Released under the MIT License.
# modified RaiMan 2016

from __future__ import with_statement

from org.sikuli.basics import Debug as JDebug

class Debug(JDebug):

Debug.log(3, "Jython: sikuli: Sikuli: starting init")
import time
import __builtin__
# import __main__
import types
import sys
import os
import inspect
import subprocess

Debug.log(4, "Jython: sikuli: Sikuli: backports from Version 2: Do")
import org.sikuli.script.Do as Do

Debug.log(4, "Jython: sikuli: Sikuli: RunTime, Setting, Debug")
import org.sikuli.script.RunTime as JRunTime

class RunTime(JRunTime):

Any help would be appreciated. Tried some items found on this site, but I still run into the module error.

c:\SikuliX contains sikuli versions

java 8 is running

Question information

English Edit question
SikuliX Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best RaiMan (raimund-hocke) said :

you posted this question earlier on stack overflow. I put an answer there.

please stick to one forum until answered or at least add reference links for posts in other forums.

Revision history for this message
hcuthbert (howard-cuthbert) said :

Thanks RaiMan, that solved my question.