Macbook M2: needs 2.0.6+

Asked by Abhay Kalla

Need help with the below error on my Macbook M2 (MacOS Ventura) when I try to run scripts in Sikulix

Exception in thread "Thread-27" java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
 at com.sun.jna.Memory.malloc(
 at com.sun.jna.Memory.<init>(
 at com.sun.jna.ptr.ByReference.<init>(
 at com.sun.jna.ptr.IntByReference.<init>(
 at org.sikuli.script.runners.AbstractScriptRunner.runAbortable(
 at org.sikuli.script.runners.AbstractScriptRunner.runSynchronized(
 at org.sikuli.script.runners.AbstractScriptRunner.runLines(
 at org.sikuli.ide.EditorPane$
 at java.base/

Java Version is:

openjdk version "17.0.6" 2023-01-17
OpenJDK Runtime Environment Temurin-17.0.6+10 (build 17.0.6+10)
OpenJDK 64-Bit Server VM Temurin-17.0.6+10 (build 17.0.6+10, mixed mode)

Question information

English Edit question
SikuliX Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best RaiMan (raimund-hocke) said :

you have to use the 2.0.6-SNAPSHOT version on

I am developing on Macs Mx with Temurin-11/17/19 and everything is fine.

Revision history for this message
Abhay Kalla (abhaykalla) said :

Thanks it works great :)

Revision history for this message
Abhay Kalla (abhaykalla) said :

Thanks RaiMan, that solved my question.