Error with runnable jar outside of IDE

Asked by Ralph

Hi RaiMan, When I export a runnable jar from Eclipse I get an error when I run the jar outside of the IDE. The error happens when I use click, hover, findtext and exists functions. The errors I get are "java.lang.NoClassDefFoundError: Could not initialize class org.sikuli.script.Finder$FindInput2" and "Caused by: java.lang.NullPointerException: Cannot invoke "" because "this.fSxBase" is null"

I read in some of the documentation that I may need to install Sikuli on the PC first but cannot find out how to do this. Any help would be appreciated

The OS is Windows 10. This is from the pom



Question information

English Edit question
SikuliX Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best RaiMan (raimund-hocke) said :

Could you please try with version 2.0.5.

Be sure, that the runnable jar contains all the Sikulix API dependencies (fat jar).

Revision history for this message
Ralph (rnimbin) said :

Thanks RaiMan, that solved my question.

Revision history for this message
Ralph (rnimbin) said :

Hi RaiMan, much appreciated. Using a fat jar with 2.0.4 fixed this error