[error] RobotDesktop: checkMousePosition: should be L[841,559]@S(0) - but is not!

Asked by reda benslal


i'm using a Sikuli 2.0.4 on a Windows 7 64bit java 8. and i have this script that is supposed to do a software installtion on a VM. the script worked fine untill yesterday, i kept getting this error log whenever i run it :
[error] RobotDesktop: checkMousePosition: should be L[841,559]@S(0) - but is not!
Possible cause in case you did not touch the mouse while script was running:
Mouse actions are blocked generally or by the frontmost application.
You might try to run the SikuliX stuff as admin.
CLICK on L[841,559]@S(0) (522 msec)

and on the screen, there was a Fatal Error popup: System.out is brooken (consol output)! you will not see any messages anymore save your work and restart the IDE (there was no IDE opened to start with)

i also think it's worthy to mention that the script is running via a TeamCity agent. and the errors only occure when an RDP session over to the machine where the script is being executed is not established

if you don't mind do you have any idea what could cause such errors? is there any thing i could do to avoid comming accross with them? do you think upgrading to 2.0.5 would help?

i'll be available to provide any extra information that can help you understand my situation. thanks in advance

Question information

English Edit question
SikuliX Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
RaiMan (raimund-hocke) said :

should first be a question

Revision history for this message
RaiMan (raimund-hocke) said :

a running script on the target machine needs an active user session and a real screen to act on (or a simulated/fake screen).

So this seems only to be the case, when an RDP session to the remote system is active.

So check your setup.

Revision history for this message
reda benslal (redabenslal) said :

thank you for the reply, i'll make sure to verify thoroughly the host set up, hopefully it's just a matter of that

Can you help with this problem?

Provide an answer of your own, or ask reda benslal for more information if necessary.

To post a message you must log in.