random function definition error

Asked by martin matias garcia on 2021-05-26

I have the following problem, when writing a script I define functions in the following way "Def function ():" everything is perfect until one generates an error. And it starts throwing "undefined function". I completely delete the function that generated the error and all the functions that worked perfectly show the same "function not defined" error. I close everything and take a break. The next day I start again and the script that gave me an error works perfectly. Until it presents the same error and I cannot continue.

Question information

Language:
English Edit question
Status:
Solved
For:
SikuliX Edit question
Assignee:
No assignee Edit question
Solved by:
martin matias garcia
Solved:
Last query:
Last reply:
Revision history for this message
RaiMan (raimund-hocke) said :
#1

SikuliX version?

Hope your mean "def function ():" ;-)

Could you paste a snippet, that allows to reproduce?

Revision history for this message
martin matias garcia (lordmmg) said :
#2

I found the problem, running the full script after repairing the function solves my problem, thanks