Sikulix On Raspberry Pi ubuntu 21.04

Asked by Dhugald Spry on 2021-05-18

I'm trying to get SikuliX working on a Raspberry Pi using Ubuntu 21.04 for a class project, when running the .jar file using the terminal I get:

[DEBUG]startUp: IDE: Running: /home/ai-drone/Desktop/Sikulix/sikulixide-2.0.5.jar
[DEBUG]startUp: IDE: AppData: /home/ai-drone/.Sikulix
[DEBUG]startUp: IDE: starting with classpath: sikulixide-2.0.5.jar ...
[DEBUG]startUp: IDE: no extensions.txt nor valid content
[1046 debug] RunTime:temp folder ok: /tmp/Sikulix_639792892
Options: *** options dump
Options: testing =
Options: OptionsFile = /home/ai-drone/.Sikulix/SikulixStore/SikulixOptions.txt
Options: *** options dump end
***** show environment for 2.0.5 API
user.home: /home/ai-drone
work dir: /home/ai-drone/Desktop/Sikulix
running on Linux 5.11.0-1008-raspi from a jar
running Java Ubuntu 11.0.11+9-Ubuntu-0ubuntu2
java.io.tmpdir: /tmp
app data folder: /home/ai-drone/.Sikulix
executing jar: /home/ai-drone/Desktop/Sikulix/sikulixide-2.0.5.jar
*** classpath dump sikulix
  0: sikulixide-2.0.5.jar
*** classpath dump end
***** show environment end
[DEBUG]startUp: IDE: *********************** leaving start
[124 debug] Sikulix: starting IDE
[181 debug] RunTime:temp folder ok: /tmp/Sikulix_1262869449
[233 debug] Screen: initScreens: starting
[234 debug] Screen: Accessing: GraphicsEnvironment.getLocalGraphicsEnvironment()
[234 debug] Screen: Accessing: GraphicsEnvironment.getLocalGraphicsEnvironment().getScreenDevices()
[243 debug] Screen: ScreenDevice 0 has (0,0) --- will be primary Screen(0)
[244 debug] Screen: Monitor 0: (0, 0) 1920 x 1080
[323 debug] Screen: initScreens: monitor mouse check
[449 debug] Screen: *** checking: R[0,0 1920x1080]@S(0) center: (960, 540) --- OK
[474 debug] Screen: initScreens: ending
[5267 debug] RunTime:***** final cleanup at System.exit() *****
[5294 debug] FileManager: deleteFileOrFolder:
/tmp/Sikulix_1262869449
[7764 debug] RunTime:***** final cleanup at System.exit() *****
[7840 debug] FileManager: deleteFileOrFolder:
/tmp/Sikulix_639792892

I'm not great with any form of Linux but when I run it it redirects me to the macOS Linux: Support Libraries for OpenCV 4 GitHub page, I've gone through the instructions for the OpenCV and built it with the newest version (4.5.2) but it still redirects me to the page when I run it, Any ideas?

Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
SikuliX Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
RaiMan (raimund-hocke) said :
#1

When you are sure, that the OpenCV lib is ready on the system, them you have to take care for the symbolic link as mentioned in the wiki entry

Sthg. like:

cd /usr/lib/jni/ # find out
sudo ln -s libopencv_java452.so libopencv_java.so

Can you help with this problem?

Provide an answer of your own, or ask Dhugald Spry for more information if necessary.

To post a message you must log in.