Unable to install in Win 10 Pro 64bit

Asked by jatin on 2021-03-07

Hi, I just bought a new PC especially to execute a project on SikuliX.
I had installed Java but when I click on the Sikuli java file nothing happens. Any idea what I am doing wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
SikuliX Edit question
Assignee:
No assignee Edit question
Solved by:
jatin
Solved:
2021-03-19
Last query:
2021-03-19
Last reply:
2021-03-14
RaiMan (raimund-hocke) said : #1

You have to double click on the jar file or run from command line:
java -jar sikulix...jar

jatin (mrjatinkashyap) said : #2

Hi, I am double-clicking in but still, nothing happens. Below is the results of the command line:

C:\Users\Jatt>java -jar sikulix...jar
Error: Unable to access jarfile sikulix...jar

RaiMan (raimund-hocke) said : #3

java -jar sikulix...jar

means:

sikulix...jar is to be replaced by the full path to the sikulix jar you want to use

RaiMan (raimund-hocke) said : #4

be sure to use the version 2.0.5
https://raiman.github.io/SikuliX1/downloads.html

jatin (mrjatinkashyap) said : #5

I am using 2.0.5. Although I was able to solve last glitch in my command but now it is showing below:

C:\Users\Jatt>java -jar C:\Users\Jatt\Downloads\sikulixide-2.0.5-win.jar
Exception in thread "main" java.lang.ExceptionInInitializerError
        at org.sikuli.script.support.RunTime.<clinit>(RunTime.java:45)
        at org.sikuli.ide.Sikulix.main(Sikulix.java:13)
Caused by: org.sikuli.script.SikuliXception: SikuliX fatal Error: System must be 64-Bit
        at org.sikuli.script.support.Commons.<clinit>(Commons.java:38)
        ... 2 more

C:\Users\Jatt>

jatin (mrjatinkashyap) said : #6

I had double-checked that my Win 10 is a 64 bit OS.

Manfred Hampl (m-hampl) said : #7

What is the output of

java -version

RaiMan (raimund-hocke) said : #8

Your Java must be a 64-Bit version.

jatin (mrjatinkashyap) said : #9

C:\Users\Jatt>java -version
java version "1.8.0_281"
Java(TM) SE Runtime Environment (build 1.8.0_281-b09)
Java HotSpot(TM) Client VM (build 25.281-b09, mixed mode, sharing)

C:\Users\Jatt>

RaiMan (raimund-hocke) said : #10

seems to be 32-Bit.

Please check.

jatin (mrjatinkashyap) said : #11

I updated it to 64 bit. And the first time it shows the below message before opening up the SikuliX GUI but for the next attempts, the GUI opens up without even the below message. Just wanted to confirm shall I worry about the message that I got on the first attempt(below shown).

C:\Users\Jatt>java -jar C:\Users\Jatt\Downloads\sikulixide-2.0.5-win.jar
[error] FileManager: writeStringToFile: did not work: C:\Users\Jatt\AppData\Roaming\Sikulix\SikulixStore\lastUsedJar.txt
C:\Users\Jatt\AppData\Roaming\Sikulix\SikulixStore\lastUsedJar.txt (The system cannot find the path specified)

RaiMan (raimund-hocke) said : #12

just ignore it. It is just a first time usage problem, with no effect. will be fixed in 2.0.6

RaiMan (raimund-hocke) said : #13

does it work now?

If yes, please mark this question as solved.

jatin (mrjatinkashyap) said : #14

Thanks!