[2.0.5] Linux: App.Open(some.sh) does not work and hangs

Asked by Javier Gonzales Rodriguez on 2021-03-05

Hello there ....

I did an update from [SikuliX 2.0.4] to [SikuliX 2.0.5] and I got an issue when I try to use: App.Open('/home/user/Documents/App/start-app-launcher.sh') ... When I execute this code on version 2.0.4 it opens the app properly and returns to my sikuliX IDE or execute the rest of the code, but when I run that code on 2.0.5 it keeps waiting and never returns to my sikuliX IDE or execute the rest of the code.

it happens with "sikulixide-2.0.5-lux.jar" and "sikulixide-2.0.5.jar"

Am using:
Linux Mint 20.1 Cinnamon
Kernel: 5.4.0-58-generic
Jython: 2.7.2
Python: Python 3.8.5

Did something change on the new version?, should I set something manually?

Regards!

Question information

Language:
English Edit question
Status:
Open
For:
SikuliX Edit question
Assignee:
No assignee Edit question
Last query:
2021-04-04
Last reply:
2021-04-03
RaiMan (raimund-hocke) said : #1

I will check and come back.

If urgent, try instead with Jython's os.Popen
https://www.jython.org/jython-old-sites/docs/library/subprocess.html

Hello there RaiMan,

Thanks for your reply, of course it worked.

Am just wondering if you found an issue on sikuliX 2.0.5 (App.Open)

Thanks, regards!

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

RaiMan (raimund-hocke) said : #5

I am on the way to get my Ubuntu working ;-)

Having done the meetings with the the EasterBunny, I will surely find a way out.

Thanks RaiMaan!

I know you will, we appreciate your help!

Thanks!

Can you help with this problem?

Provide an answer of your own, or ask Javier Gonzales Rodriguez for more information if necessary.

To post a message you must log in.