[2.0.5] Windows: OCR not working on some machines --- VC Redist 2015+ x64 needed

Asked by Chetan on 2021-03-04

--------------- look here
https://github.com/RaiMan/SikuliX1/wiki/Windows:-Problems-with-libraries-OpenCV-or-Tesseract

-----------------------------------------------------------

In build 2.0.5 when we run findWord("text") then we get error and test fails
however on same machine 2.0.4, it worked fine
is this a possible bug or some new VC is required?
OS windows Java 14

  File "C:\p4\Automations\FeatTests\Common\UIAutomation\acrobat.sikuli\acrobat.py", line 35, in start
    preFlightChecks()
  File "C:\p4\Automations\FeatTests\Common\UIAutomation\acrobat.sikuli\acrobat.py", line 58, in preFlightChecks
    control=findWord("Home")
SikuliXception: org.sikuli.script.SikuliXception: OCR: start: Tesseract library problems: The specified module could not be found.

debug logs
[debug] Region: Key.WIN as modifier
[debug] ( Windows ) TYPE "#UP."
[debug] Region: ( Windows ) TYPE "#UP."
[debug] RunTime:loadlib: trying opencv_java430
[debug] RunTime:addToWindowsSystemPath: added to systempath:
C:\Users\labuser\AppData\Roaming\Sikulix\SikulixLibs
[debug] RunTime:libsExport: folder created: C:\Users\labuser\AppData\Roaming\Sikulix\SikulixLibs (2.0.5 - 202103030910)
[debug] RunTime:loadLib: opencv_java430.dll (success)
[debug] RunTime:loadlib: trying opencv_java430
[debug] RunTime:resourceLocation: (class org.sikuli.script.support.RunTime) /tessdataSX
[debug] RunTime:resourceList: having jar: jar:file:/C:/p4/Automations/FeatTests/Common/UIAutomation/sikulixapi-2.0.5.jar!/tessdataSX
[debug] RunTime:files exported: 11 from: /tessdataSX to:
 C:\Users\labuser\AppData\Roaming\Sikulix\SikulixTesseract\tessdata
[debug] OCR: start: Tess4J 4.5.4 using Tesseract 4.1.x
[debug] Finder2: makeMat: INT_RGB (1024x768)
[error] see: https://github.com/RaiMan/SikuliX1/wiki/Windows:-Problems-with-libraries-OpenCV-or-Tesseract
[error] Save your work, correct the problem and restart the IDE!

Question information

Language:
English Edit question
Status:
Solved
For:
SikuliX Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2021-03-04
Last query:
2021-03-04
Last reply:
2021-03-04
RaiMan (raimund-hocke) said : #1

You should check about the state of the VC Redistributable on the failing systems.

You need a x64 version 2015+

On my Win10 it works with VC Redist 2015 x64.

Chetan (cshamdas) said : #2

on the Win10 machine it had 2015 X86 14.0.2
after installing VC 2015-2019 X64 14.28 it started working. this was not required with build 2.0.4
is this now needed with new build?

Best RaiMan (raimund-hocke) said : #3

SikuliX is 64-Bit only in all aspects from now on.

So yes, you have to make sure that everything needed is 64-Bit.

Chetan (cshamdas) said : #4

Thanks RaiMan, that solved my question.