Trying to install sikulixide on raspberry pi 4

Asked by Debojit Bhowmick on 2021-02-02

I am trying to install sikulixide on raspberry pi 4. but every time while trying to run the jar file encountering the following error
[DEBUG]startUp: IDE: Running: /home/pi/SikuliX/sikulixide-2.0.4.jar
[DEBUG]startUp: IDE: AppData: /home/pi/.Sikulix
[DEBUG]startUp: IDE: starting with classpath: sikulixide-2.0.4.jar ...
[DEBUG]startUp: IDE: no extensions.txt nor valid content
[DEBUG]startUp: IDE: adding extension file: /home/pi/.Sikulix/Extensions/jython-standalone-2.7.2.jar
Exception in thread "main" org.sikuli.script.SikuliXception: fatal: Java arch must be 64 Bit (java 11 version 11 vm 11.0.9.1+1-post-Raspbian-1deb10u2 class 55.0 arch null)
 at org.sikuli.script.support.RunTime.get(RunTime.java:977)
 at org.sikuli.script.support.RunTime.get(RunTime.java:915)
 at org.sikuli.script.support.RunTime.start(RunTime.java:132)
 at org.sikuli.ide.Sikulix.main(Sikulix.java:13)

I am tried to launch older sikuli instances, have installed opencv and tesseract and still no breakthrough. I am newbie in the field of linux, but have been using sikulix for years on windows. Could I get some pointers as to how to make this possible?

Question information

Language:
English Edit question
Status:
Answered
For:
SikuliX Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
RaiMan (raimund-hocke) said :
#1

2.0.4 needs a 64-Bit Java version, hence only runs on 64-Bit systems.

If 32-Bit arch is mandatory, you have to try with Java 8 and older SikuliX versions.

... but I cannot help you:
- I do not support older SikuliX versions any longer
- with Linux I do not have experiences as well, that might be enough for your situation

Can you help with this problem?

Provide an answer of your own, or ask Debojit Bhowmick for more information if necessary.

To post a message you must log in.