Exception in thread "Thread-22" java.lang.ExceptionInInitializerError and PY Issue

Asked by Mur Bes on 2020-11-14

Greetings all,

I'm trying to install and making some basic scripts since the morning but i can't because these issues. Since i started, i tried many things and have read all setup documents, watched videos etc.

First of all, when i trying to run jar,it's saying that at the right side:

Exception in thread "Thread-22" java.lang.ExceptionInInitializerError
 at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:100)
 at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:94)
 at org.python.util.PythonInterpreter.<init>(PythonInterpreter.java:71)
 at org.sikuli.script.runnerSupport.JythonSupport.init(JythonSupport.java:93)
 at org.sikuli.script.runnerSupport.JythonSupport.get(JythonSupport.java:66)
 at org.sikuli.script.runners.JythonRunner.doInit(JythonRunner.java:87)
 at org.sikuli.script.runners.AbstractScriptRunner.init(AbstractScriptRunner.java:70)
 at org.sikuli.ide.EditorPane$2.run(EditorPane.java:360)
Caused by: java.lang.IllegalArgumentException: Cannot create PyString with non-byte value
 at org.python.core.PyString.<init>(PyString.java:57)
 at org.python.core.PyString.<init>(PyString.java:70)
 at org.python.core.PyString.<init>(PyString.java:74)
 at org.python.core.Py.newString(Py.java:647)
 at org.python.core.PyJavaType.init(PyJavaType.java:585
)
 at org.python.core.PyType.createType(PyType.java:1523)
 at org.python.core.PyType.addFromClass(PyType.java:1462)
 at org.python.core.PyType.fromClass(PyType.java:1551)
 at org.python.core.PyObject.<init>(PyObject.java:93)
 at org.python.core.PySingleton.<init>(PySingleton.java:9)
 at org.python.core.PyNotImplemented.<init>(PyNotImplemented.java:10)
 at org.python.core.Py.<clinit>(Py.java:94)
 ... 8 more

Secondly, i'm trying to make a basic script and can't run it because it says:

[error] IDE: Run Script: internal error:
org.sikuli.script.SikuliXception: Cannot initialize Script runner Jython
 at org.sikuli.script.runners.AbstractScriptRunner.init(AbstractScriptRunner.java:78)
 at org.sikuli.script.runners.AbstractScriptRunner.runSynchronized(AbstractScriptRunner.java:362)
 at org.sikuli.script.runners.AbstractScriptRunner.runScript(AbstractScriptRunner.java:167)
 at org.sikuli.ide.SikulixIDE$ButtonRun$1.run(SikulixIDE.java:2468)
 at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.NullPointerException
 at org.sikuli.script.runnerSupport.JythonSupport.interpreterExecString(JythonSupport.java:306)
 at org.sikuli.script.runners.JythonRunner.doInit(JythonRunner.java:94)
 at org.sikuli.script.runners.AbstractScriptRunner.init(AbstractScriptRunner.java:70)
 ... 4 more

And finally, i saw it's on PY format even i switched my tab into jython. Is it normal? I'm very newbie.

And here are the screenshots.

https://i.hizliresim.com/7U15y1.png
https://i.hizliresim.com/D78VCo.png
https://i.hizliresim.com/WAiyFJ.png

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2020-11-15
Last reply:
2020-11-15

This question was reopened

RaiMan (raimund-hocke) said : #1

looks odd.

supposing it is 2.0.4

- what system? what Java?

Did you follow the steps from the download page?

sikulixide...jar
jython...jar

downloaded in one folder.

Run from a command line:

java -jar sikulixide....jar -v -c

send me the text output to sikulix---at---outlook---dot---com

Mur Bes (murbes) said : #2

openjdk version "11.0.9" 2020-10-20
OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.9+11)
OpenJDK 64-Bit Server VM AdoptOpenJDK (build 11.0.9+11, mixed mode)

Windows 10, ofc i followed many things. I searched for similar issues and your reccomendation to other questions etc.. I'm sending now, thank you so much..

RaiMan (raimund-hocke) said : #3

Apparently you have the following problem:

folder C:\Users\Murat\Desktop\deneme.sikuli

contains another deneme.sikuli

I guess this gets Sikuli confused ;-)

take care, that C:\Users\Murat\Desktop\deneme.sikuli
only contains a deneme.py
and the images you have captured for that script

DO NOT have any subfolders or other stuff than that in your C:\Users\Murat\Desktop\deneme.sikuli

Mur Bes (murbes) said : #4

I deleted and still have same issue. On the other hand, tried to make new script and new folder and same issue.

RaiMan (raimund-hocke) said : #5

Ok, I simulated your setup:

- win10 and java 11

- sikulixide in C:\Users\rmhde\Desktop\SIKULIX\sikulixide-2.0.4.jar

- jython-standalone-2.7.1.jar in place

- script in C:\Users\rmhde\Desktop\deneme.sikuli
the folder only contains a deneme.py

- using this runs the script as expected:
java -jar C:\Users\rmhde\Desktop\SIKULIX\sikulixide-2.0.4.jar -v -r C:\Users\rmhde\Desktop\deneme.sikuli

same goes for the IDE: script can be loaded and run

Can you help with this problem?

Provide an answer of your own, or ask Mur Bes for more information if necessary.

To post a message you must log in.