SikuliX wrong resolution Windows 10

Asked by Mychajlo Chodorev on 2020-09-01

Hi all.
I've downloaded and started SikuliX 2.0.4 on my Windows 10 laptop. The screen resolution is 1920x1080. When I try to make a screenshot the screen's resolution is changed to smaller one so I can't capture topmost right corner. If I capture required part of the screen with external tool and refer captured file I get following error:

    [error] FindFailed ( next.png: (33x33) in R[0,0 1280x720]@S(0) )

How do I make it to use proper resolution?

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2020-09-05
Last query:
2020-09-05
Last reply:
2020-09-05
Mychajlo Chodorev (ralfeus) said : #1

Running same script in virtual Windows 2012 R2 via RDP with same resolution (1920x1080) works fine

RaiMan (raimund-hocke) said : #2

see: bug 1730645

might be the reason

Mychajlo Chodorev (ralfeus) said : #3

I'm not sure about Java version.
The java.com states this about latest download:

Recommended Version 8 Update 261
Release date July 14, 2020

There is no mention of Java 9, 10 or 11. So I'm a bit lost in versioning

RaiMan (raimund-hocke) said : #4

What about your Windows monitor settings?

Mychajlo Chodorev (ralfeus) said : #5

Indeed change of scale to 100% from 150% did help.
However that would mean I have to change scaling every time I start SikuliX script.
I understand the workaround would be to change JRE version. Where do I find one? Is it official Oracle's one or some other?

Best RaiMan (raimund-hocke) said : #6

for private, personal use the best place is
https://adoptopenjdk.net

Mychajlo Chodorev (ralfeus) said : #7

Thanks RaiMan, that solved my question.