PLEASE HELP! Use Python in SikuliX IDE?

Asked by Pedro Lebre on 2020-08-29

Hello friends.

I need a little help getting back on track.

I have used SikuliX 1.0 (I think) since ~2013. Recently, I had to change work computers and the newest version was installed which I believe is Sikuli X 2.0.4 but it looks VERY different and none of my old files work.

I believe in SikuliX 1.0 from docs.sikuli.org was in python but I could be very wrong. I am not a programmer but used Sikuli to automate silly little data entry projects. All of them were very simple click and type projects and I created over 200 of them. My code is very simply, something like this:

#Type Column Name (from a spreadsheet)
    type(row['Last Name'])
    type('\t')
    type('\t')

    type(row['First Name'])
    type('\t')
    type('\t')

#TYPE SSN
    type(row['SSN'])
    type('\t')

#TYPE DOB
    type(row['Month'])
    type('\t')
    type(row['Day'])
    type('\t')
    type(row['Year'])
    type('\t')

But none of my files work with SikuliX 2.0.4 and I think it's using a different language. Java? I even tried simple code like click and type and it did not work.

What am I doing wrong? Please explain to me like I am 5 years old. I am not a programmer.

Thank you so much.

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Pedro Lebre
Solved:
2020-09-03
Last query:
2020-09-03
Last reply:
2020-08-29
RaiMan (raimund-hocke) said : #1

How do you run the scripts? Do you use the IDE?

If SikuliX is installed correctly it should run your scripts (the standard still is Python(Jython)).

What are the symptoms when you say "But none of my files work"?

Any error messages?

Pedro Lebre (sikulischool) said : #2

Thank you for responding.

I was able to fix this.

The solution was to add both the sikulix-2.0.1 jar file AND the sikulixide-2.0.4 jar file in the same directory.

Once I did this, everything worked.

Previously, I only had the sikulix-2.0.1 jar file on my machine.

Thank you so much.