Best install method for linux mint ver20?

Asked by arminius on 2020-08-04

The best I've managed is getting "sikulix-2.1.0.jar" to run, but it keeps throwing error messages like "javax.script.ScriptException:"
I'm pretty sure it's not installed right.

Question information

English Edit question
SikuliX Edit question
No assignee Edit question
Last query:
Last reply:
arminius (arminius75) said : #1

It's really weird, if I fish out some old Sikuli code, then "wait" is it's familier light blue, "if" is navy blue.

But any new code I try to write has no coloring, it's all just black font.

arminius (arminius75) said : #2

the "wait" is it's familier light blue.
Is what I ment.

arminius (arminius75) said : #3

either I use "sikulixide-2.0.4.jar" or "sikulix-2.1.0.jar"
it doesn't matter, same problem.

RaiMan (raimund-hocke) said : #4

seems you do not have Jython available and are running as JavaScript.


arminius (arminius75) said : #5

That's probably the problem, when I downloaded "jython-standalone-2.7.1.jar" nothing happened when I ran it, and yes I made it executable.
So I ran it in the command line and it said

    user@computer:~/Downloads$ java -jar jython-standalone-2.7.1.jar -v -c
    Argument expected for the -c option
    user@computer:~/Downloads$ java -jar jython-standalone-2.7.1.jar
    WARNING: An illegal reflective access operation has occurred

There was alot more after the WARNING.

So I googled for other Jython installers and found "jython-installer-2.7.2.jar" which ran just fine, so I presumed that wasn't the issue.

RaiMan (raimund-hocke) said : #6

just follow the steps on the mentioned page and use version 2.0.4 in any case.

Purge everything else from your system, that you have tried before.

arminius (arminius75) said : #7

I give up, been trying for hours.
Jython will not execute, it must not be compatible with this version of linux mint.
I'll try again in a few months.
Thanks for trying.

Hi Arminius,

It is compatible, am using mint 19 + and 20 and it works!

install the jython-installer-2.7.1.jar, and then sikulixide-2.0.4.jar

Open sikulixIDE and then go to "file>open special files" ..... and change this line, example: jython = /home/mint/jython2.7.1/jython.jar
Save it, close and open the sikulixIDE again.

then run all this commands:
sudo apt install libcanberra-gtk0 libcanberra-gtk-module
sudo apt install libopencv4.2-java openjdk-11-jre-headless
cd /usr/lib/jni/
sudo ln -s
sudo apt-get install xdotool
sudo apt-get install wmctrl
sudo add-apt-repository ppa:alex-p/tesseract-ocr
sudo apt-get update
sudo apt install tesseract-ocr
sudo apt install libtesseract-dev
sudo ldconfig

hope this helps.


Can you help with this problem?

Provide an answer of your own, or ask arminius for more information if necessary.

To post a message you must log in.