Help with setting Sikuli Up

Asked by Ethan Perry on 2020-07-24

I'm very new to programming in general, and I'm having trouble getting Sikuli to even run. Whenever I run any line I get this error message:
javax.script.ScriptException: ReferenceError: "Commands" is not defined in nashorn:mozilla_compat.js at line number 67

In another question, I saw that the person had not had the jython standalone jar installed, but to my knowledge I do have it. I checked in app data and it is in the extensions folder for Sikuli, I tried deleting the sikuli file and the jython file but it changed nothing. Am I doing something wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
masuo
Solved:
2020-07-25
Last query:
2020-07-25
Last reply:
2020-07-25
masuo (masuo-ohara) said : #1

Did you read this page?
http://sikulix.com/quickstart/

Ethan Perry (1m4) said : #2

Yes, as far as I know I followed everything (its how I found this forum)

Ethan,

Am a beginner too so am gonna share what i did for Linux ...

I downloaded the "sikulixide-2.0.4.jar" and "jython-installer-2.7.1.jar", installed first the jython and then sikulixide.

After that I opened the sikulixide and selected "File > Special files > entered the number 2 > configure the path of your jython, like this: jython = /home/mint/jython2.7.1/jython.jar"

Closed the sikulixide and run those commands on terminal:

sudo apt install libcanberra-gtk0 libcanberra-gtk-module
sudo apt-get install xdotool
sudo apt-get install wmctrl
sudo add-apt-repository ppa:alex-p/tesseract-ocr
sudo apt-get update
sudo apt install tesseract-ocr
sudo apt install libtesseract-dev
sudo ldconfig
sudo apt install libopencv4.2-java openjdk-11-jre-headless
cd /usr/lib/jni/
sudo ln -s libopencv_java420.so libopencv_java.so

By the way, am using python, hope that this helps to you man.

Regards!

Ethan Perry (1m4) said : #4

Thanks for the comment, unfortunately I'm on windows :P

Best masuo (masuo-ohara) said : #5
Ethan Perry (1m4) said : #6

Thanks, that's all it needed to work!

Ethan Perry (1m4) said : #7

Thanks masuo, that solved my question.