Trying to use 2.0.2 sikuli

Asked by Marc Summers on 2020-06-15

I am updating from 1.1.2 to 2.0.2
and I am getting this error even though I am importing like this:

from subprocess import call

But I still get this error in my script

[error] NameError ( !!WHILE IMPORTING!! name 'subprocess' is not defined )

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2020-06-15
Last query:
2020-06-15
Last reply:
2020-06-15
Best RaiMan (raimund-hocke) said : #1

2.0.2 is no longer supported - use 2.0.4

Follow the instructions on the download page (especially about Jython).

Marc Summers (2aircraft) said : #2

OK, got 2.0.4 working OK on Windows 10 64bit
the problem I had was that for some reason
in version 1.1.2 I was able to make a subprocess call
with out having to explicitly add
import subprocess in the script

So all I have to do is to add this to each of my
scripts, and everything works OK.

Thanks for your help RaiMan :)