opencv_java342.dll: Can't find dependent libraries

Asked by Colin Lin on 2020-05-26

hello! I am using SikuliX 2.0.4 in my computer which os is windows embedded standard system (Service Pack 1 ) and I got some error.
error : C:\Users\Admin.AUTOBVT-NJMAC0R\AppData\Roaming\Sikulix\SikulixLibs\opencv_java342.dll: Can't find dependent libraries
But I check the path there is opencv_java342.dll no doubt. I want to ask is there any solution to solve this problem? Or SikuliX just can't run in windows embedded standard system? thx

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2020-05-26
Last reply:
2020-06-24
RaiMan (raimund-hocke) said : #1

This might be the problem with special Windows editions, that do not include the media library dll's.

Look for a solution, to get this stuff on your system.

Colin Lin (colinlin0812) said : #2

Thanks RaiMan!
Basically SikuliX can run in Wes7 ? If I download the media library dll's and put into my computer, I might be able to solve this problem?

RaiMan (raimund-hocke) said : #3

--- Basically SikuliX can run in Wes7 ?
I do not know - never tested - never heard about

--- If I download the media library dll's and put into my computer, I might be able to solve this problem?
Just give it a try - the only thing I know related to special Win editions

Colin Lin (colinlin0812) said : #4

And I found the api-ms-win-downlevel-shlwapi-l1-1-0.dll is not in my Wes7 system.
Do I need to download and put into the folder path which are C:\Windows\System32\ and C:\Windows\SysWOW64?

RaiMan (raimund-hocke) said : #5

as mentioned: no experiences.

Colin Lin (colinlin0812) said : #6

OK! Thanks RaiMan
I'll give it a try

Colin Lin (colinlin0812) said : #7

Sorry I want to ask another question:
In order to solve this problem, I take another computer which os is win7 professional version. And I also used sikulixide 2.0.4 but when I doubleclick the sikulixide, the jython interpreter move to extension folder but ide is not showing.
I want to ask is there any solution to solve this problem?

Colin Lin (colinlin0812) said : #8

Hello RaiMan!
I download the media library dll from internet(http://www.dlldownloader.com/media-dll/#Mediadll-Explanation) and put into my computer(C:\Windows\System32\ and C:\Windows\SysWOW64)
But the problem is still the same. When I take screen image, the sikulix show error message and lead me to the website(https://github.com/RaiMan/SikuliX1/wiki/macOS-Linux:-Support-Libraries-for-OpenCV-4)

RaiMan (raimund-hocke) said : #9

the download page says about Jython:
Download what you prefer or both to the same folder as you have your sikulix.jar.
They will be recognized by SikuliX at the next start and moved to the SikuliX's extension folder.
So preferably download before using the IDE the first time.

... and
If you have any problems, run this from a commandline and analyse the log output
java -jar path-to/sikulix.jar -v -c

Colin Lin (colinlin0812) said : #10

I download both to the same folder and I know jython will move to extension folder.
I expect when I click the sikulixide.jar, message will show up like "sikuliX ide is starting on java 8" and open sikulixide, but nothing happened.
I wonder if sikulixide doesn't show up, can I still use the commandline to print the log out?

RaiMan (raimund-hocke) said : #11

yes - hope you already tried out ;-)

Can you help with this problem?

Provide an answer of your own, or ask Colin Lin for more information if necessary.

To post a message you must log in.