[2.1.0] SikuliX IDE does not work with JDK 14

Asked by Nobunaga Oda on 2020-04-20

Hello.
Sikulix IDE does not work in the following environment.
Do you need any other settings? It worked fine with openjdk version "12.0.2".
I don't think it works when the OS is Japanese.

Environment:
------------
OS Version: Windows 10 Pro 1903(18362.778) Japanese
Sikuli version: 2.1.0-SNAPSHOT (built at 2020-04-20_11:53 (Build 606))
openjdk version "14" 2020-03-17
OpenJDK Runtime Environment (build 14+36-1461)
OpenJDK 64-Bit Server VM (build 14+36-1461, mixed mode, sharing)

Run Command:
------------
C:\>java -jar C:\sikulix\sikulix-2.1.0.jar

Output:
-------
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffa58bbf74a, pid=18516, tid=7628
#
# JRE version: OpenJDK Runtime Environment (14.0+36) (build 14+36-1461)
# Java VM: OpenJDK 64-Bit Server VM (14+36-1461, mixed mode, sharing, tiered, compressed oops, g1 gc, windows-amd64)
# Problematic frame:
# C [awt.dll+0x8f74a]
#
# No core dump will be written. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# C:\kotonoha\sikulix21\hs_err_pid18516.log
#
# If you would like to submit a bug report, please visit:
# https://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2020-04-20
Last reply:
2020-04-21
RaiMan (raimund-hocke) said : #1

I am building the runnable jars with Java 13 latest in IntelliJ IDEA running on Windows 10-64 latest (german).

I tried with Java 14.0.1 (latest) from commandline: works as expected.

Nobunaga Oda (cochrane80) said : #2

Hello.

Thank you for your answer, RaiMan.
Try again with the latest OpenJDK.
It works fine in English version of Windows OS, so there may be something wrong with the settings of Japanese version of Windows OS. The following error was logged.

--------------- T H R E A D ---------------

Current thread (0x0000027070ddb000): JavaThread "main" [_thread_in_native, id=8884, stack(0x000000c41cb00000,0x000000c41cc00000)]

Stack: [0x000000c41cb00000,0x000000c41cc00000], sp=0x000000c41cbfef90, free space=1019k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [awt.dll+0x8f74a]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j sun.awt.windows.WComponentPeer._setFont(Ljava/awt/Font;)V+0 java.desktop@14
j sun.awt.windows.WComponentPeer.setFont(Ljava/awt/Font;)V+7 java.desktop@14
j sun.awt.windows.WWindowPeer.initialize()V+42 java.desktop@14
j sun.awt.windows.WFramePeer.initialize()V+1 java.desktop@14
j sun.awt.windows.WComponentPeer.<init>(Ljava/awt/Component;)V+83 java.desktop@14
j sun.awt.windows.WCanvasPeer.<init>(Ljava/awt/Component;)V+2 java.desktop@14
j sun.awt.windows.WPanelPeer.<init>(Ljava/awt/Component;)V+2 java.desktop@14
j sun.awt.windows.WWindowPeer.<init>(Ljava/awt/Window;)V+2 java.desktop@14
j sun.awt.windows.WFramePeer.<init>(Ljava/awt/Frame;)V+2 java.desktop@14
j sun.awt.windows.WToolkit.createFrame(Ljava/awt/Frame;)Ljava/awt/peer/FramePeer;+5 java.desktop@14
j java.awt.Frame.addNotify()V+20 java.desktop@14
j java.awt.Window.pack()V+28 java.desktop@14
j org.sikuli.idesupport.IDESplash.init(Ljava/lang/String;Ljava/lang/String;)V+139
j org.sikuli.idesupport.IDESplash.<init>(Ljava/lang/String;Ljava/lang/String;)V+7
j org.sikuli.ide.SikulixIDE.main([Ljava/lang/String;)V+91
v ~StubRoutines::call_stub

siginfo: EXCEPTION_ACCESS_VIOLATION (0xc0000005), reading address 0x0000000000000058

RaiMan (raimund-hocke) said : #3

Be sure, that there is no other java/bin on the system path.

run the IDE with
java -jar <path-to>/sikulixide....jar -v -c

from commandline.

This suppresses the splash-screen at startup, which is the top of your stacktrace.

More I cannot help you. You have to google for Java 14 problems.

Nobunaga Oda (cochrane80) said : #4

Hello.

Thank you for your reply, RaiMan.

There was no other Java in the system path.

I added a parameter to the command line and printed a stack trace.
Based on the contents of the stack trace, try searching for something wrong with Java14.

thank you very much.

Can you help with this problem?

Provide an answer of your own, or ask Nobunaga Oda for more information if necessary.

To post a message you must log in.