Windows 10 japanese + SikuliX 2.0.3: needs Java 11+

Asked by 梅田香代子 on 2020-03-13


I installed sikulix for the first time.
As you do, I created a program that double-clicks the icon on the desktop to open it.


When I check it with the matching preview, the correct icon is filled.
However, the mouse clicks a different place.

In order to confirm the operation, I checked the point position with "find(iamge.png).highlight(1)".
Then, a red square was selected in a completely different place.

The fact that the icon is recognized, but a different place is selected means that there is a problem with the resolution,
so I changed the resolution and took a screenshot and tried again, but I could not do it.
Only 800 × 600 resolution, somehow succeeded.

The screen is enlarged when taking a screenshot with sikulix. Is this normal behavior?
How does it click the right place?

I thought that the installation method was bad and reinstalled twice, but it does not change.
 I also restarted my PC.

I stumbled from the beginning.
Anyone know the solution?
Sorry to trouble you, but please teach.

Question information

English Edit question
SikuliX Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
RaiMan (raimund-hocke) said : #1

what system?
what SikuliX?
what Java?

梅田香代子 (kayoko0713) said : #2

Dear RaiMan

Thank you for your reply!

Below is my environment

system-> Windows10(japanese)
SikuliX-> sikulix 2.0.3
java-> jre-8u241-windows-x64

Please let me know if anything is missing.

Best RaiMan (raimund-hocke) said : #3
梅田香代子 (kayoko0713) said : #4

Dear RaiMan

Thank you for useful information!!
Exactly, this bug seems to apply!

However, after installing 11.0.6 jdk and running sikulix,
An error file with the PID was output, and startup failed...

Is any command operation necessary?

I'm afraid that it will be another problem,
Please tell me more if you know about it.

RaiMan (raimund-hocke) said : #5

run from commandline

<path-to>\java.exe -jar <path-to>\sikulix-2.0.3.jar -v -c

to get some startup log.

Take car that nothing else but Java 11 stuff is referenced (Systempath, environment, ...)

梅田香代子 (kayoko0713) said : #6

Dear RaiMan

Thank you for your advice.

I tried to output the log and checked it, it seemed that a bug occurred here as well.

[2342 debug] IDE startup: 2.3 seconds *** Running on Java 9+
# A fatal error has been detected by the Java Runtime Environment:
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007fffeb0cfd3e, pid=12236, tid=6092
# JRE version: Java(TM) SE Runtime Environment (11.0.6+8) (build 11.0.6+8-LTS)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (11.0.6+8-LTS, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)
# Problematic frame:
# C [awt.dll+0x8fd3e]


I thought that it was incompatible, I tried with OpenJDK version 10, but that was also bad (it stops again with another error in the middle of processing)

finally, I tried it with OpenJDK version 11, and it worked! ! !
The mouse moves as I wish.

I did not think that the behavior changed so much with the JAVA version.
Thanks to you.

The following environment was found to be stable for me.

system-> Windows10(japanese)
SikuliX-> sikulix 2.0.3
java-> jdk-11

Thank you for your time!

梅田香代子 (kayoko0713) said : #7

Thanks RaiMan, that solved my question.