SyntaxError Non-ASCII character in file

Asked by Nitin Chaudhari on 2020-03-05

Hi RaiMan,
Am having SikuliX 2.0.3 and xlrd 1.2.0.
Using xlrd to read excel file. But getting error at the begining itself.
--------------------------------------------------
error] script [ Excel_Read ] stopped with error in line 1
[error] SyntaxError ( Non-ASCII character in file 'C:\Users\tibco2\AppData\Roaming\Sikulix\Lib\xlrd\licences.py',
but no encoding declared; see http://www.python.org/peps/pep-0263.html for details )
[error] --- Traceback --- error source first
line: module ( function ) statement
11: __init__ ( <module> ) from . import licences
1: main ( <module> ) import xlrd
[error] --- Traceback --- end --------------
--------------------------------------------------
By refering other threads; have modified the licences.py, __init__ .py. with " # -*- coding: utf-8 -*- ".
Still getting the same error.

What could be the reason and possible solution for above error.

Regards,
Nitin Chaudhari

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
19 hours ago
Last query:
19 hours ago
Last reply:
2020-03-05
Best Manfred Hampl (m-hampl) said : #1

There seems to be something wrong with your xlrd Installation.
As far as I know xlrd 1.2.0 does not have a licences.py file.
I suggest that you remove everything related to xlrd from your system and install it again.

Nitin Chaudhari (cnitin) said : #2

Hi Manfred,
I shall do xlrd installtion again and will let you know; if issue persists.

Rgards,
Nitin Chaudhari

Nitin Chaudhari (cnitin) said : #3

Thanks Manfred Hampl, that solved my question.