I can not open SikuliXIDE-2.1.0-SNAPSHOT(build 565)

Asked by masuo on 2020-03-01

I can open SikulixIDE-2.1.0-SNAPSHOT(build 478).
But I can not open SikuliXIDE-2.1.0-SNAPSHOT(build 565).

[OS:]
Windows10 , 64 bit Build 18362 (10.0.18362.329)

(1)Oracle Java8 + SikulixIDE-2.1.0-SNAPSHOT(build 478)
SikuliXIDE open successfuly.

(2)Oracle Java8 + SikuliXIDE-2.1.0-SNAPSHOT(build 565)
SikuliXIDE does not open.

[Java:]
java version "1.8.0_211"
Java(TM) SE Runtime Environment (build 1.8.0_211-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.211-b12, mixed mode)

[SikuliX:]
SikuliXIDE-2.1.0-SNAPSHOT(build 565)

[Error:]
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/sikuli/script/support/RunTime$Type has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0

(3)OpenJDK13 + SikuliXIDE-2.1.0-SNAPSHOT(build 565)
SikuliXIDE does not open.

[Java:]
openjdk version "13.0.2" 2020-01-14
OpenJDK Runtime Environment (build 13.0.2+8)
OpenJDK 64-Bit Server VM (build 13.0.2+8, mixed mode, sharing)

[SikuliX:]
SikuliXIDE-2.1.0-SNAPSHOT(build 565)

[Error:]
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007fff8a74f98a, pid=13740, tid=7908
#
# JRE version: OpenJDK Runtime Environment (13.0.2+8) (build 13.0.2+8)
# Java VM: OpenJDK 64-Bit Server VM (13.0.2+8, mixed mode, sharing, tiered, compressed oops, g1 gc, windows-amd64)
# Problematic frame:
# C [awt.dll+0x8f98a]
#
# No core dump will be written. Minidumps are not enabled by default on client versions of Windows
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
masuo
Solved:
2020-03-29
Last query:
2020-03-29
Last reply:
2020-03-01
RaiMan (raimund-hocke) said : #1

yes, I am sorry, but 2.1.0 snapshot will need Java 9+ for now.
Not sure, whether I will make it available for Java 8 again.

So for the moment stay with the latest build that works for you or upgrade to OpenJDK 13.02 (recommended).

masuo (masuo-ohara) said : #2

@RaiMan, thank you for your answer.
Already I have tried OpenJDK13 + SikuliXIDE-2.1.0-SNAPSHOT(build 565).
The result was not good. ( --> #1 (3) )

Do I need to configure anything for OpenJDK13?

RaiMan (raimund-hocke) said : #3

I do not have any problems here:

running 64Bit(amd64) on w (10.0) from a jar
java 13 version 13 vm 13.0.2+8 class 57.0 arch 64

run from commandline with -v -c

BTW: just pushed a fix for another thing: it is now #566 ;-)

maybe you have some older java stuff on systempath or something like this???

masuo (masuo-ohara) said : #4

Now I can open SikuliXIDE-2.1.0-SNAPSHOT build#:603

[Java:]
openjdk version "11.0.2" 2019-01-15
OpenJDK Runtime Environment 18.9 (build 11.0.2+9)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.2+9, mixed mode)