Unable to Install SikuliX 2.0.X on Win Server 2012 R2

Asked by Nitin Chaudhari on 2020-02-28

Hi Raiman,
Thanks for excllednt support always.

Installing SikuliX 2.0.3 on Windows Server 2012 R2 (64 bit).
This machine have multiple Java versions for various other applications.
The versions are jre 1.4.2_06, jre1.6.0_07, jre1.8.0_66.
Java version by default refering was 1.4(Refer below Log)
------------------------------
Remote Server Java Version
Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.
C:\Users\XXXXX>java -version
java version "1.4.2_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_06-b03)
Java HotSpot(TM) Client VM (build 1.4.2_06-b03, mixed mode)
C:\Users\XXXX>
------------------------------
Googled and found that changing envirronment variable we can change Java version.
By changing environment variable in path explisitly am able to see that the Java varsion is chnaged to 1.8.(Refer log)
------------------------------
Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.
C:\Users\XXXX>java -version
java version "1.8.0_66"
Java(TM) SE Runtime Environment (build 1.8.0_66-b35)
Java HotSpot(TM) Client VM (build 25.66-b35, mixed mode, sharing)
C:\Users\XXXX>
------------------------------
And then again tried to install SikuliX. still am unable to install SikuliX.
Have ran the insatller with command prompt to refer issue log. Refer below.
--------------------------------
C:\Users\XXXX>java -jar C:\Users\XXXXX\Desktop\SikuliX\sikulix-2.0.3.jar -v -
c
[DEBUG]startUp: IDE: Running: C:\Users\XXXX\Desktop\SikuliX\sikulix-2.0.3.jar
[DEBUG]startUp: IDE: AppData: C:\Users\XXXX\AppData\Roaming\Sikulix
[DEBUG]startUp: IDE: starting
[DEBUG]startUp: IDE: no extensions.txt nor valid content
[DEBUG]startUp: IDE: moving to extensions: C:\Users\XXXX\Desktop\SikuliX\jytho
n-standalone-2.7.1.jar
[DEBUG]startUp: IDE: adding extension: C:\Users\XXXX\AppData\Roaming\Sikulix\Extensions\jython-standalone-2.7.1.jar
Exception in thread "main" org.sikuli.script.SikuliXception: fatal: Java arch must be 64 Bit (java 8 version 1.8 vm 25.66-b35 class 52.0 arch null)
        at org.sikuli.script.support.RunTime.get(RunTime.java:952)
        at org.sikuli.script.support.RunTime.get(RunTime.java:890)
        at org.sikuli.script.support.RunTime.start(RunTime.java:113)
        at org.sikuli.ide.Sikulix.main(Sikulix.java:13)

C:\Users\XXXX>
--------------------------------
Seems changing the environment variable is not helping in this case.
Is there way to tell SikuliX installer to refer the required java version installed(ie Java 1.8)?
Or any way out for installaion?

Removing other Java version will impact other application running on server.

Appreciate your advise.
Regards,
Nitin Chaudhari

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Nitin Chaudhari
Solved:
2020-03-06
Last query:
2020-03-06
Last reply:
2020-02-28
RaiMan (raimund-hocke) said : #1

as mentioned:
Exception in thread "main" org.sikuli.script.SikuliXception: fatal: Java arch must be 64 Bit

your Java is 32-Bit

I recommend to install the OpenJDK 13 and use the JAVA_HOME setting for SikuliX only.

Nitin Chaudhari (cnitin) said : #2

Hi Raiman,
Thanks for valuable suggestions. This solved my problem.

Regards,
Nitin Chaudhari