[2.0.x] Windows: type() problems running from commandline --- due to wrong active keyboard layout

Asked by Nobunaga Oda on 2019-11-16

**************** possible solution from the linked bug report:

It can be due to wrong active keyboard layout. I had the issue when I tried to type('s', Key.CTRL) whilst Ukrainian layout was active, which has no latin symbols

Run [Settings] > [Time & Language] > [Language] > [Spelling, typing, & keyboard settings] >
[Advanced keyboard settings] on Windows 10.
When [Override for default input method] was changed to [Use language list (recommended)],
no error occurred!

--------------------------------------------------------------------------
Hello.
Executing the following script from the command line results in an error.
It runs normally when run from the IDE.
How can I solve it?

Environment:
------------
OS Version: Windows 10 Home 1809(17763.864)
Sikuli version: 2.0.0
Java version: openjdk version "12.0.2" 2019-07-16

Script:(sikulix-test.sikuli ---> sikulix-test.py)
-------------------------------------------------
1 type('r', Key.WIN)

Run Command:
------------
C:\projects\sikulix-test>java -jar C:\sikulix\sikulix-2.0.0.jar -r sikulix-test.sikuli

Output:
-------
[log] ( メタ ) TYPE "r"
[error] script [ sikulix-test ] stopped with error in line 1
[error] java.lang.IllegalArgumentException ( java.lang.IllegalArgumentException: Key: Not supported character: r )
[error] --- Traceback --- error source first
line: module ( function ) statement
1: main ( <module> ) type('r', Key.WIN)
[error] --- Traceback --- end --------------

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-16
Last reply:
2020-01-11
RaiMan (raimund-hocke) said : #1

This is a helpful question

RaiMan (raimund-hocke) said : #2

possible solution from the linked bug report:

It can be due to wrong active keyboard layout. I had the issue when I tried to type('s', Key.CTRL) whilst Ukrainian layout was active, which has no latin symbols

Run [Settings] > [Time & Language] > [Language] > [Spelling, typing, & keyboard settings] >
[Advanced keyboard settings] on Windows 10.
When [Override for default input method] was changed to [Use language list (recommended)],
no error occurred!