Unsupported Error

Asked by dongleilin on 2019-08-22

java.lang.UnsupportedClassVersionError: org/sikuli/ide/Sikulix : Unsupported major.minor version 52.0
 at java.lang.ClassLoader.defineClass1(Native Method)
 at java.lang.ClassLoader.defineClassCond(Unknown Source)
 at java.lang.ClassLoader.defineClass(Unknown Source)
 at java.security.SecureClassLoader.defineClass(Unknown Source)
 at java.net.URLClassLoader.defineClass(Unknown Source)
 at java.net.URLClassLoader.access$000(Unknown Source)
 at java.net.URLClassLoader$1.run(Unknown Source)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
 at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
 at java.lang.ClassLoader.loadClass(Unknown Source)
Could not find the main class: org.sikuli.ide.Sikulix. Program will exit.

Hi,I got error message when run the skl file at Jenkins...
I know there are the other issue #674103 got the same situation.
Can I know why?

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2019-08-22
Last reply:
2019-08-22
RaiMan (raimund-hocke) said : #1

the SikuliX class to be loaded is of Java byte code version 8.

seems you are running a Java version 7 on the Jenkins system.

Can you help with this problem?

Provide an answer of your own, or ask dongleilin for more information if necessary.

To post a message you must log in.