Classpath problem inside maven project

Asked by Sebastian Ebner on 2019-07-09

My poms are too big to be copied in here but in general i am just using the dependency from your https://github.com/RaiMan/SikuliX-2014/wiki/How-to-use-with-Maven page.

    <dependency>
        <groupId>com.sikulix</groupId>
         <artifactId>sikulixapi</artifactId>
         <version>1.1.1</version>
    </dependency>

Clean install and builds are working fine, same as the local execution.

Im only having problems once my build transfers the jars to my execution server where i am getting:

    [error] RunTimeINIT: *** terminating: libs to export not found on above classpath: /sikulixlibs/windows/libs64

when i try to run it. I checked the built jars and only

   sikulix1tigervnc-1.1.1.jar
   sikulixapi-1.1.1.jar
   sikulixlibslux-1.1.1.jar

seem to be there.

Any idea what could be wrong here?

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2019-07-10
Last query:
2019-07-10
Last reply:
2019-07-10
RaiMan (raimund-hocke) said : #1

are dev machine and exec machine both Windows?

what Java version is on each machine?

I tried on Windows 10 with Java 8 with a Maven project in IntelliJ IDEA and had no problems.

Sebastian Ebner (sybner) said : #2

Thanks for the response, both win10 , java8

The problem might be that the exec server has no 'real' screen as referred in your documentation:

  -- Real Screen needed
  The system running SikuliX scripts or any apps using SikuliX features must
  have a real screen connected. So called headless systems are not supported
  (Java restriction). While using SikuliX features, the screen should not be
  in sleep mode nor show a screen saver. It must be in a state, that a user
  could work with the system and watch on the screen what is going on.

  -- Using Virtual Machines
  Running it in VM guest systems as the above mentioned should usually work,
  but might have quirks.

I have a monitoring server who is connected to all my other vms so a client is always connected.

Best RaiMan (raimund-hocke) said : #3

Yes might be the problem.

Connected clients do not help, as long as the SikuliX features are used in the server context.

You have to run some fake screen like xvfb on linux systems.

Sebastian Ebner (sybner) said : #4

Thanks RaiMan, that solved my question.