Click does not work

Asked by Rafal Stankiewicz on 2019-06-20

Good morning,

I developed Java app that uses Sikulix 1.1.3 (with 1.1.1 the same problem). I'm using Windows 10 (100% screen scale), Java (I was trying 8, 9, 10, 11 - and always the same issue). App starts with admin privileges.

My problem is that Sikulix sometimes does not click on the image (randomly). Mouse is always moving to image but click does not occur (i see that on the movie that is recorded during app is running). For example: app does several iterations (mouse moves to image and clicks) and suddenly it stops clicking - mouse moves to the picture but does not click.

I was reading about similar issues but no solution works for me.

I'm doing Region region = wait(image, time) and then region.click();

Could you give me any hints how could I cope with this?

Thank you. Regards

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Rafal Stankiewicz
Solved:
2019-06-25
Last query:
2019-06-25
Last reply:

This question was reopened

Rafal Stankiewicz (rafalstank) said : #1

Mentioned Windows 10 is a laptop that I connect to via VNC Viewer (server is TightVNC)

Rafal Stankiewicz (rafalstank) said : #2

I clicked with right mouse button on java.exe and in properties (compatibility table) I set to run java with admin privileges. Issue seems to be solved.

Rafal Stankiewicz (rafalstank) said : #3

solved

Rafal Stankiewicz (rafalstank) said : #4

I encountered the problem again. After more then 1k correct iterations, app did not click image. Uff.. Did anyone have such problem?

Rafal Stankiewicz (rafalstank) said : #5

False alarm. Client admitted that his application hung for a minute and that was a cause of sikuli exception :)

matteoa (matteoa) said : #6

Hello,we are running more or less the same setup with ultravnc.
We are having the same problems of missing clicks after thousands of cycles; something that mitigate the problem is to force a refresh of ultravnc...I think that this way maybe Ultravnc sends the click that was done but not received/sent.
I also tried with some success to change a click with a doubleclick...
Anyway the problem is still there, mitigated but...

Rafal Stankiewicz (rafalstank) said : #7

Hello, two weeks have passed and I did not notice problems anymore. It seems that running jvm with admin privileges helped. For a moment I had switched off admin privileges option and it failed. Have you tried run your app invoker (jvm/whatever) with admin privs? But still no idea why that fixed the issue.