How to disable Sikuli Logging on Java?

Asked by Bryan on 2019-05-22

I'm developing Sikuli on Java. Sikuli overrides the logger I'm using on my framework. How can I disable it? Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2019-05-23
Last query:
2019-05-23
Last reply:
2019-05-22
Best RaiMan (raimund-hocke) said : #1

Debug.off() // any debugging messages
Settings.ActionLogs = false; // messages from click, ...
Settings.InfoLogs = false; //other information messages

... but I doubt, that it has something to do with the SikuliX own logging implementation, which is completely independent of any Java logging concept.

What logging are you using?

Have a look at the maven deps of sikulixapi.jar, something like slf4j might be the problem.

Bryan (bryanvaldellon) said : #2

Thank you for the reply RaiMan. the snippet that you sent above does not work for me. Tried to delete the slf4j binder class on the jar and it works now.
BTW, I'm using logback classic.

Thank you!

Bryan (bryanvaldellon) said : #3

Thanks RaiMan, that solved my question.