IDE has switches to a different IME

Asked by IAN ROBINSON on 2019-04-12

Hi

I've been experimenting with calling external scripts and retrieving data.
The script text in the IDE is now show in some foreign characters.... maybe arabic (I have ENG as my default)

The Preferences is set to English, The Message panel is in English... errr ???

I tried re-installing... still wrong...

Please can you help.

Thanks
IAN

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
IAN ROBINSON
Solved:
2019-04-15
Last query:
2019-04-15
Last reply:
2019-04-15
RaiMan (raimund-hocke) said : #1

SikuliX generally only works with files encoded in UTF-8.

This has nothing to do with the language your GUI is running with.

So if you use other editors with SikuliX scriptfiles, you have to take care, that the file encoding is UTF-8.

A modern editor usually has an option to set the default encoding for new files. The encoding of existing files should be recognized and not changed, when saved again.

IAN ROBINSON (ian.robinson) said : #2

Hi RaiMan

All my scripts are UTF-8 encoded... editing the same script (.py) in NotePad++ shows this as normal.
Also loading the same script onto another machine (although this is a Windows7 system) shows the text correctly.

anything else you can suggest ?

RaiMan (raimund-hocke) said : #3

Sorry, I now realized, that I completely misunderstood your problem.

But now I have to say again sorry:
I have no idea.

If it is not SikuliX itself, then the only candiadte left is your Java environment, where something might have been changed by your experiments.

IAN ROBINSON (ian.robinson) said : #4

Got to the Bottom of this.
For some unknown reason the IDE default Font had changed
from 'monospaced' to 'AlienCaret' (first one in the list)

all happy now...
sorry for wasting your time

Thanks
IAN

RaiMan (raimund-hocke) said : #5

no problem, glad it is solved.