Latest sikulix installer does nothing when double clicked

Asked by MP on 2019-04-06

preq: installed latest JAva / phython

Double clicking the jar file doesnt do anything...
So I was forced to install 1.1.3 which works like normal.

Using win 10 64bit

Any help would be cool!

Thx!

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2019-04-08
Last query:
2019-04-08
Last reply:
2019-04-07
MP (jozzzzzz) said : #1

I tryed the command line
java -jar path-to/sikulix.jar

But then I get the next error message:

https://ibb.co/L161L5K

RaiMan (raimund-hocke) said : #2

SikuliX 1.1.4 needs 64-Bit system and Java!

MP (jozzzzzz) said : #3

Did you even read my topic? I have 64bit AND java installed....

MP (jozzzzzz) said : #4

Did you even read my topic? I have 64bit AND java installed....

masuo (masuo-ohara) said : #5

@MP
You have to fix the "path-to" part based on your environment.

MP (jozzzzzz) said : #6

Please look at t he link, the picture shows you the error I am getting. There is nothing wrong with the path.... Rofl, does none read topics? -_-

Best RaiMan (raimund-hocke) said : #7

--- Rofl, does none read topics?
please keep calm and polite.

The Java used at runtime is not a 64-Bit version, but must be for SikuliX.

use
java -version
to show, what you are running.

You should revise your system setup, to make sure, that a Java 64-Bit version is used when running java from a command line or when double clicking sikulix.jar.

MP (jozzzzzz) said : #8

Thank you! That was the problem! It has to be 64 bit java version!

It works lovely now! thx again!

MP (jozzzzzz) said : #9

Thanks RaiMan, that solved my question.