Unable to install OpenCV 2.4.x and Tesseract 3.0.2 and libopencv_core.so.2.4 libopencv_imgproc.so.2.4 libopencv_highgui.so.2.4 libtesseract.so.3

Asked by monicar on 2019-02-01

Hi,

I am getting the following error while running Sikuli scripts on Grid through Jenkins.
Hub : Red Hat Enterprise Linux Server release 7.6 (Maipo)
Node Win10

09:35:50 [error] RunTimeINIT: fatal error: java.io.IOException: Cannot run program "lsb_release": error=2, No such file or directory
09:35:50 [error] RunTimeAPI: loadLib: libVisionProxy.so not usable:
09:35:50 java.lang.UnsatisfiedLinkError: /var/lib/jenkins/.Sikulix/SikulixLibs_201711011200/libVisionProxy.so: libopencv_core.so.2.4: cannot open shared object file: No such file or directory
09:35:50 [error] RunTimeAPI: loadLib: libVisionProxy.so not usable:
09:35:50 java.lang.UnsatisfiedLinkError: /var/lib/jenkins/.Sikulix/SikulixLibs_201711011200/libVisionProxy.so: libopencv_core.so.2.4: cannot open shared object file: No such file or directory
09:35:50 [info] runcmd: ldconfig -p
09:35:50 [error] LinuxSupport: checking: OpenCV not in loader cache (see doc-note on OpenCV)
09:35:50 [error] LinuxSupport: checking: Tesseract not in loader cache (see doc-note on Tesseract)
09:35:50 [error] RunTimeAPI: Problematic lib: /var/lib/jenkins/.Sikulix/SikulixLibs_201711011200/libVisionProxy.so (...TEMP...)
09:35:50 [error] RunTimeAPI: libVisionProxy.so loaded, but it might be a problem with needed dependent libraries
09:35:50 ERROR: ...TEMP...: libopencv_core.so.2.4: cannot open shared object file: No such file or directory
09:35:50 [error] RunTimeAPI: *** terminating: problem with native library: libVisionProxy.so

I tried to install following :

libopencv_core.so.2.4
libopencv_imgproc.so.2.4
libopencv_highgui.so.2.4
libtesseract.so.3

Getting below msg:
[root@rsaautotesting ~]# yum install libopencv_highgui.so.2.4
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
No package libopencv_highgui.so.2.4 available.
Error: Nothing to do

Please advice and also share the commands to install libraries neccesary to run Sikuli script on RHEL(Linux)

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2019-02-01
Last reply:
2019-02-03
RaiMan (raimund-hocke) said : #1

Does not look like version 1.1.4 !?

I do not support older versions of SikuliX any more with such system specific problems.

Can you help with this problem?

Provide an answer of your own, or ask monicar for more information if necessary.

To post a message you must log in.