Can't launch mac desktop app from SikuliX

Asked by Melvin Raymond on 2019-01-22

I'm running SikuliX on Mojave. I can open apps like Text Editor, and other apps via the IDE, but I do not seem to be able to launch our application that I want to write tests for.

This works: App.open ("/Applications/TextEdit.app") and will open the Text Editor
This fails: App.open("/Applications/Viewer.app") and posts an error "...Viewer.app not found"

I can invoke the Viewer.app from the Mac terminal
I can also create a "thing.py" file and run it with "./thing.py" from the terminal but even that when configured in SikuliX won't invoke even though it invokes the app fine from the terminal.

I've looked around in the forums and Google and worked with a developer to try and get this working. Both of us are new at Python and SikuliX. I have been able to run a Demo to test my setup and that worked fine.

Using Python 2.7.10
Using SikuliXIDE 1.1.3
Using Mac os: Mojave 10.14.2

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Melvin Raymond
Solved:
2019-01-22
Last query:
2019-01-22
Last reply:
2019-01-22
RaiMan (raimund-hocke) said : #1

Try with latest 1.1.4

Melvin Raymond (fribian) said : #2

Thank you Raiman for the quick turn around!

OK, I got that up and running and it does appear to let me invoke my app now. So just to clarify, this is a nightly build and I'll need to upgrade once 1.1.4 is released?

RaiMan (raimund-hocke) said : #3

While using 1.1.4 nightly, you should check for new builds from time to time.

... and yes: once the final is out, you should upgrade to it.

Melvin Raymond (fribian) said : #4

Thanks Raiman. Good to stay on top of it. Our main projects will be
starting soon so I'll probably end up backing off it once that starts.

On Sat, Feb 16, 2019 at 1:42 AM RaiMan <email address hidden>
wrote:

> Your question #677975 on Sikuli changed:
> https://answers.launchpad.net/sikuli/+question/677975
>
> RaiMan posted a new comment:
> While using 1.1.4 nightly, you should check for new builds from time to
> time.
>
> ... and yes: once the final is out, you should upgrade to it.
>
> --
> You received this question notification because you asked the question.
>

--
Mel Raymond - Quality Assurance Engineer
<email address hidden>

Vernier Software & Technology

13979 SW Millikan Way

Beaverton, OR 97005

www.vernier.com