[1.1.4] Windows: can't find dependent libraries using function Region.text()

Asked by Edson Henrique Arantes on 2019-01-11

I'm on windows 7 64 bits sp1, using the IDE 1.1.4 jar file, I have the jython 2.7 installed

sikulix 1.1.4 works fine until I used the text() function, it stops the execution and give the error at

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.r

eflect.Method.invoke(Unknown Source)
java.lang.UnsatisfiedLinkError: java.lang.UnsatisfiedLinkError: Não foi possível encontrar o módulo especificado. (can not find the module, it does not say wich one)

looks like something is missing

using java 8 64 bits 192

please help

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2019-01-16
Last reply:
2019-01-22
RaiMan (raimund-hocke) said : #1

pleas try again with the latest build from today

I'm donwloading from here https://raiman.github.io/SikuliX1/downloads.html

I don't know if this is the last build, any way, it did not work, same error =/

I have windows 10 installed (this win 7 is from virtual box) and on win 10 works fine (same java version installed)

RaiMan (raimund-hocke) said : #4

please read through bug 1797505

I did everything that I could find in the given link, nothing solved the problem =/

install all java versions, intall opencv, python, jython, downloded last build available, update windows. copy paste dll's

the error only occurs with the text() function, so must be ocr dll

I will continue to search for a solution, tips are welcome

RaiMan (raimund-hocke) said : #6

Sorry, but for the next 3 weeks I cannot do anything related to Windows.

run
java -Dsikuli.Debug=3 -jar sikulix.jar

after having cleaned all you did her
.... install all java versions, intall opencv, python, jython, downloded last build available, update windows. copy paste dll's
(from comment #3)

Nothing of all this stuff besides a valid Java (which you seem to have) is needed.
... ok, and Jython according to the steps mentioned on the download page.

RaiMan (raimund-hocke) said : #7

... hopefully, the debug output reveals more.

Can you help with this problem?

Provide an answer of your own, or ask Edson Henrique Arantes for more information if necessary.

To post a message you must log in.