Sikuli v1.1.4 not starting

Asked by Joseph Maruca on 2019-01-10

Hi folks,

I recently downloaded Sikuli v1.1.4 for Windows 10 x64 (was using v1.1.3 IDE). When selecting - Siulix.jar, the following message appears:

Neither Jython nor JRuby available
IDE not yet useable with JavaScript only
Please consult the docs for a solution

I downloaded and installed both Jython and JRuby; restarted and the same message appears!

Can you please assist?, thank you. regards, Joe

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2019-01-10
Last query:
2019-01-10
Last reply:
2019-01-10
Best RaiMan (raimund-hocke) said : #1

--- downloaded and installed
If you follow the advice on the SikuliX download page:
"Needed for scripting support in the IDE and running scripts from commandline"

it should work.

Joseph Maruca (jmaruca) said : #2

Got it now RaiMan, thanks again for your help.

Joseph Maruca (jmaruca) said : #3

Thanks RaiMan, that solved my question.

Ed Chmiel (edthec-csd) said : #4

Did not work for me - I installed jython to c:\skiuli (windows), and then placed sikulix.jar into that folder. Double clicking the jar gives the "neither jython nor.." error.

RaiMan (raimund-hocke) said : #5

@ed
please follow exactly the steps on the downloadpage (no need to INSTALL jython).

Ed Chmiel (edthec-csd) said : #6

Thank you for the reply, but I still encounter the same problem. My steps on a win 10 machine:
- created a new folder c:\SikuliX
- downloaded into that folder:
   sikulixapi.jar
   jythoninstaller-2.7.0.jar
   sikuliax.jar
- java -version = 1.6.0_24 , SE 1.6.0_24-b07 and hoptspot 64 bit server build 19.1-b02

Double click sikulix.jar and get the same error.

I am confused by the java - i downloaded what i thought was the latest and wonder if that is the problem?

I downloaded openjdk-12.0.1_windows-x64_bin.zip, but I could not find out what to do with it. There no install other than the instruction to unzip (to where?) nor readme.

Thanks in advance.

RaiMan (raimund-hocke) said : #7

@ed
sorry, but you are not doing, waht is mentioned on the download page:

--- Download the ready to use sikulixapi.jar
This artefact is for use on a Java classpath or for Java programming in mature IDEs as library jar.

so if you do not want to program in java, you do not need that !

--- so you want to use the SikuliX IDE:
Needed for scripting support in the IDE and running scripts from commandline
The Jython interpreter 2.7.1 for python scripting (the default)
Download what you prefer or both to the same folder as you have your sikulix.jar.
They will be recognized by SikuliX at the next start.
So preferably download before using the IDE the first time.

Download the ready to use sikulix.jar (SikuliX IDE)
Just download, move it to a folder of your choice and doubleclick to run it.
An alternative to run it is from commandline using
java -jar path-to/sikulix.jar

I think that is rather clear.

Nothing is said about a jython installer.

So please do as mentioned.

Ed Chmiel (edthec-csd) said : #8

Ah, further investigation finds I had 2.7.0 NOT 2.7.1 of jython as required.
Not sure how that happened.

Apologies for missing that at first - thank you for your prompt responses.

Any plans for a simpler windows installer? IE an exe that does everything (checks Java, download the right files, etc)?

RaiMan (raimund-hocke) said : #9

No, there will never again be an installer.