Unable to click after test is executed

Asked by Akos Kovacs on 2019-01-08

I use SikuliX IDE Build 179 on Windows 8.1 and in some cases I am unable to use right click after test is executed. Mouse is not working properly. When I do a single click all the text below that line is highlighted or more than one icon is highlighted after a single click.

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-01-15
Last query:
2019-01-15
Last reply:
2019-01-08
Manfred Hampl (m-hampl) said : #1

"... When I do a single click all the text below that line is highlighted ..."
This sounds as if the ctrl key is pressed at that time.

Does this strange behavior persists if you press and release the ctrl key?

Do you have a keyDown(Key.CTRL) in your code without corresponding keyUp()?

Manfred Hampl (m-hampl) said : #2

... or eventually the Key.SHIFT and/or key.ALT keys ...

Akos Kovacs (plaidshirtakos) said : #3

It happens after type() method is executed. I don't call keyDown() method.

Best Manfred Hampl (m-hampl) said : #4

Which keyboard settings does you system have? US English keyboard or something else?

For potential problems with type() see your other question https://answers.launchpad.net/sikuli/+question/676661 comment #1

Akos Kovacs (plaidshirtakos) said : #5

@Manfred Hampl: It was caused by type() method. Thanks for your help!

Akos Kovacs (plaidshirtakos) said : #6

Thanks Manfred Hampl, that solved my question.