Sikulix IDE not launching Jython/JRuby

Asked by Ken Thompson on 2019-01-04

Hello all,

Sikulix IDE is not launching. I just receive a small window stating
"IDE not useable"
"Neither Jython nor JRuby available. IDE not yet useable with JavaScript only
Please consult the docs for a solution"

1. I downloaded ready-to-use "sikulix.jar"
2. I use JavaPortableLauncher64 to run the sikulix because the company only allows
JRE6 to be used and admin rights to change it. Through JPL64 I run it using JRE8.
3. I checked the JAR file and it only comes a JavaScript folder containing "commands.js"
There's no Jython folder or anything.
4. I think I need to add Jython somehow, but don't know how to link it.

Best regards,

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Ken Thompson
Solved:
2019-01-05
Last query:
2019-01-05
Last reply:
Ken Thompson (kennycarga) said : #1

I didn't mean to be vague in my first question, I actually did
follow the insturctions on the download page:

>>>
The Jython interpreter 2.7.1 for python scripting (the default)
The JRuby interpreter 9.x for ruby scripting
Download what you prefer or both to the same folder as you have your sikulix.jar.
They will be recognized by SikuliX at the next start.
So preferably download before using the IDE the first time.
>>>

but didn't do it.
Best regards,

Ken Thompson (kennycarga) said : #2

Ouch sorry for wasting your time.
I double checked and it turns out, the JRuby jar was not in the same folder as Jython and sikulix.jar.
When I placed BOTH jars together in the same folder as sikulix.jar it actually launched.

Sorry for wasting your time.

Best regards,