[1.1.4] findAll: behaviour seems to differ from 1.1.3: not all visible images are found in some cases

Asked by alex on 2018-12-01

So far I have been using findAll without any issues.
But since I switched to version 1.14 of SikuliX it often fails to find all instances of an image.

I am running the same script (with the exception of having a region) on the same UI as I did with earlier versions where it worked flawlessly.
But now my loop

for x in reg.findAll(image.png)
    reg.click(x)

often fails to click on all instances of the image. It usually omits 1-2 instance out of 4-5 on screen. On the screen, the images are all within the defined region reg.

Edit: tried again without a region. Still the same issue

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-12-01
Last reply:
2018-12-02
RaiMan (raimund-hocke) said : #1

can you send me an example (image and shot with images visible)?
sikulix---at---outlook---dot---com

Can you help with this problem?

Provide an answer of your own, or ask alex for more information if necessary.

To post a message you must log in.