unsatisfied link error: no opencv_java in java.library.path

Asked by Desire on 2018-11-08

I'm trying to use sikulix on my Centos 7 machine. We are trying to embark on the endeavor at my job to start automating some test procedures.

I installed OpenCV and Tesseract. And installed all necessary rpms that i found on this page and other blog posts and I'm trying to use the newest version of sikuli which is 1.1.4.

additional rpms that i installed prior:

yum install gcc
yum install cmake
yum install git (should already have this installed)
yum install gtk2-devel
yum install pkgconfig
yum install python-pip
yum install numpy
yum install python-devel
yum install ant
libpng-devel libjpeg-turbo-devel jasper-devel openexr-devel libtiff-devel libwebp-devel (for various image files)
yum install python devel python-nose python-setuptools gcc gcc-gfortran gcc-c++ blas-devel lapack-devel atlas-devel

There was even opencv rpms which i also installed to see if it got rid of the error but still had same error.

When i try to run java -jar sikulix.jar i get the error:

[error] RunTimeIDE: loadLib: opencv_java not usable:
java.lang.UnsatisfiedLinkError: no opencv_java in java.library.path
[error] RunTimeIDE: *** terminating: problem with native library: opencv_java

But from everything I read after building Opencv i should have libopencv_java343.so library which was generated under my /usr/local/share/OpenCV/java/ folder.

So my question is what is this opencv_java library that it's asking for? None of the information I have found even mention this library. Any help will be appreciated.

Question information

Language:
English Edit question
Status:
Expired
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-11-09
Last reply:
2018-11-25
RaiMan (raimund-hocke) said : #1

Read and follow the docs for Linux in the 1.1.4 section

Desire (db2020) said : #2

I have read and followed the instructions in the 1.1.4 section and still receive that error for an opencv_library.

> On Nov 9, 2018, at 1:32 AM, RaiMan <email address hidden> wrote:
>
> Your question #676029 on Sikuli changed:
> https://answers.launchpad.net/sikuli/+question/676029
>
> Status: Open => Answered
>
> RaiMan proposed the following answer:
> Read and follow the docs for Linux in the 1.1.4 section
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/sikuli/+question/676029/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/sikuli/+question/676029
>
> You received this question notification because you asked the question.

RaiMan (raimund-hocke) said : #3

Symbolic link in library path?

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

Spencer (spencersomething128) said : #5

I can confirm this is still an issue.

I followed these instructions to install opencv on mint

https://opencv-java-tutorials.readthedocs.io/en/latest/01-installing-opencv-for-java.html#install-opencv-3-x-under-linux

i keep getting this error:
RunTimeIDE: loadLib: opencv_java not usable:
java.lang.UnsatisfiedLinkError: no opencv_java in java.library.path

i can't figure out how to link to the opencv_java.so because i can't find it... i only know where the

libopencv-java346.so

and the

opencv-346.jar

is.

please help!