crash when the java software start to run

Asked by aobahou on 2018-10-28

Hi RaiMan,

My software will crash sometimes(about 1 in 5).
The java version is 1.8.0_171 and sikulix version is 1.1.2.
The hs_err_pid.log file shows:
Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j org.sikuli.natives.VisionProxyJNI.new_FindInput__SWIG_0()J+0
j org.sikuli.natives.FindInput.<init>()V+1
j org.sikuli.script.Finder.<init>(Lorg/sikuli/script/ScreenImage;Lorg/sikuli/script/Region;)V+24
j org.sikuli.script.Region.doCheckLastSeenAndCreateFinder(Lorg/sikuli/script/ScreenImage;Lorg/sikuli/script/Image;DLorg/sikuli/script/Pattern;)Lorg/sikuli/script/Finder;+282
j org.sikuli.script.Region.findInImage(Lorg/sikuli/script/ScreenImage;Ljava/lang/Object;)Lorg/sikuli/script/Match;+73
j org.sikuli.script.Region.access$000(Lorg/sikuli/script/Region;Lorg/sikuli/script/ScreenImage;Ljava/lang/Object;)Lorg/sikuli/script/Match;+3
j org.sikuli.script.Region$SubFindRun.run()V+20
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub

Thanks a lot.

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-10-28
Last reply:
2018-10-28
RaiMan (raimund-hocke) said : #1

if possible, make a test with version 1.1.4.

Take care to be able to fully step back, if needed.

aobahou (aobahou) said : #2

Thanks for answering. I am wondering if I transfer from 1.1.2 to 1.1.4, "the latest Visual C++ Redistributable Pack (>=2013) installed" is a necessary condition´╝č

Is there anything way to avoid install latest Visual C++ Redistributable Pack?

Thanks alot.

RaiMan (raimund-hocke) said : #3

Try without

Can you help with this problem?

Provide an answer of your own, or ask aobahou for more information if necessary.

To post a message you must log in.