Remote Testing With Sikuli VNC

Asked by joseph paul on 2018-10-23

I am attempting to click on images on a remote desktop computer. I am using UltraVNC with SikuliX running in an eclipse environment. When I execute the script i get a FindFailed error. Can I use UltraVNC with SikuliX.1.1.3? I am connecting to the remote computer with the following line in my script:

VNCScreen vncscreen=org.sikuli.script.Sikulix.vncStart("", 5900, 10, 1000);

Question information

English Edit question
Sikuli Edit question
No assignee Edit question
Last query:
Last reply:
RaiMan (raimund-hocke) said : #1

Possible to try with SikuliX 1.1.4?

The type of backend (UltraVNC in your case) should not matter.

with 1.1.4 use this in Java::
VNCScreen vncscreen=org.sikuli.vnc.vncScreen.start("", 5900);

make a test with a oneliner:

BTW: "" is not a "remote" connection. the server is expected on the same machine (locally).

In doubt do some debugging and check the relevant VNCScreen object variables after the start is done.

Another problem might be, that directly after the start the Framebuffer is not yet filled completely - insert some wait.

joseph paul (josephpaul) said : #2

I have captured the screen at the remote computer and it is all distorted. I have also double clicked on the VNCViewer and connected to the remote and the picture of the desktop is viewable except the images are larger. I still run my script and get a FindFailed error. Do you really think this problem will go away if i use 1.1.4? Thanks. Not sure what else to do.

joseph paul (josephpaul) said : #3

I also have a wait of 10 seconds before doing the screen capture on the remote pc

joseph paul (josephpaul) said : #4

I am using the following code to see the remote desktop....As I said previously...the image is coming out very distorted. When I connect to the remote PC with VNC\Viewer...the image of the desktop is fine but much larger than the remote screen is showing.

ScreenImage image = client.capture(client);"D:\\");

RaiMan (raimund-hocke) said : #5

--- 1.1.4: I do not support 1.1.3 anymore with such system/tool specific problems.
... and no, of course I am not sure, that 1.1.4 will do the job.

... and I still do not understand, what you are doing on what system: remote is not local (

so please be more precise, so I have a chance to test with my setup.

joseph paul (josephpaul) said : #6

Sorry...i am not using loopback but rather an IP address for the remote...I am taking an image on the remote desktop with the snipping tool. Then in am clicking on that image from another computer with a selenium webdriver script in eclipse which has sikuli imported. I keep getting a findfailed error.

RaiMan (raimund-hocke) said : #7

I cannot help you, since I do not have your setup and really do not finally understand, what you are doing.

So I leave you alone now - you have to debug yourself.

joseph paul (josephpaul) said : #8

ok thank you

Launchpad Janitor (janitor) said : #9

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Miguel Garcia (hlodowig) said : #10

Hello RaiMan,

I'm getting the same behavior that Joseph got. I'm trying to connect from my computer to a Virtual Box instance on the same machine. My environment is as follows:

- Running sikulixapi.jar 1.1.4 (downloaded today) on MacOS Mojave 10.14.2.
- java version "1.8.0_191"
Java(TM) SE Runtime Environment (build 1.8.0_191-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.191-b12, mixed mode)

- Virtual Box Win 7 (downloaded here:, running UltraVNC 1.2..23 server.

When I connect with a VNC client everything looks just fine. If i try vncscreen.userCapture(), all icons and some other elements on the remote desktop look distorted.

Thanks in advance.

Miguel Garcia (hlodowig) said : #11

Seems a UltraVNC issue. Just replaced it with TightVNC and everything worked just fine.

joseph paul (josephpaul) said : #12

yes...i believe UltraVNC is the issue.....we also have changed to TightVNC
with better results. Thanks

On Mon, Jan 7, 2019 at 12:52 PM Miguel Garcia <
<email address hidden>> wrote:

> Your question #675498 on Sikuli changed:
> Miguel Garcia posted a new comment:
> Seems a UltraVNC issue. Just replaced it with TightVNC and everything
> worked just fine.
> --
> You received this question notification because you asked the question.

Can you help with this problem?

Provide an answer of your own, or ask joseph paul for more information if necessary.

To post a message you must log in.