blocks Java Robot generated mouse actions Mac

Asked by Marc Summers on 2018-10-16

1. Running on Macintosh Mojave OS
2. 1.1.3 sikuli loaded.
3. trying to run a test I get this

[error] RobotDesktop: checkMousePosition: should be L(1878,51)@S(0)[0,0 1920x1200] <<< which is correct for this first command.

It also says Mouse actions are blocked generally.

I did not touch anything or change anything on screen, or touch the mouse.

I am running as me not as root.

So is there some setting that I have to do to allow RobotDesktop to work properly on the Macintosh ?

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Marc Summers
Solved:
2018-10-17
Last query:
2018-10-17
Last reply:
2018-10-17
RaiMan (raimund-hocke) said : #1

On Mac the app that uses SikuliX features must be listed in the privacy -> accessibility list in the System Preferences.

But if you use the SikuliX IDE, the problem should have been reported with a popup.

BTW: [error] RobotDesktop: checkMousePosition: should be L(1878,51)@S(0)[0,0 1920x1200] <<< which is correct for this first command.

... yes of course, since this is where the mouse SHOULD be, but is not as the rest of the error message tells you.

Another thing might be, that your application under test blocks mouse actions generated by Java AWT Robot.
Then IMHO there is no solution on Mac.

Marc Summers (2aircraft) said : #2

On Mac the app that uses SikuliX features must be listed in the privacy -> accessibility list in the System Preferences.

Thanks RaiMan !!!
This fixed the problem. :)