No installed runner problem --- workaround

Asked by Panos on 2018-09-10

----------------------------------- workaround
What SikuliX does:
- looks for a jython...jar, jruby....jar in the folder having the siklix jars and if found: move to folder <appdata>/Extensions (this is why the jar vanishes)
- the Extensions folder is evaluated about available runner jars (jython, jruby) and other possible jars, to be put on the java classpath

This normally works.

The workaround is to move the jar directly to the Extensions folder.

---------------------------------------------------------------------------------------------

Hello i've downloaded the new sikuli IDE n start it witn the classic java -jar path/sikulix.jar
Sikuli starts normally, except these errors that doesn't seems to be a real problem
[error] Hot key conflicts
[error] HotkeyManager: addHotkey: failed
[error] Hot key conflicts
[error] HotkeyManager: addHotkey: failed

then when i try to open an existing sikuli project (that runs just fine in another pc) this message appears
"...serious problem detected
No installed runner supports (text/python)
Trying to run the script will crash IDE"

screenshot: https://i.imgur.com/NO6NOca.png

and..it really crashes IDE

OS: PCLinuxOS Release 2018 64-bit

Ty

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
Panos
Solved:
2018-09-20
Last query:
2018-09-20
Last reply:
2018-09-19
RaiMan (raimund-hocke) said : #1

Read and understand the Download page (Jython).
Read the Linux special info in the news about 1.1.4

Panos (zappas) said : #2

Still java,tesseract xdotool,opencv etc ok but cant figure out whats the problem

RaiMan (raimund-hocke) said : #3

Jython is missing - see Download page.

Panos (zappas) said : #4

hmm true jython is missing from OS i've made a request to be added in synaptic (i also try to install it but no luck "Could not find or load main class java Caused by: java.lang.ClassNotFoundException: java")
im waiting response from them n ill close this topic
ty very much for the response

RaiMan (raimund-hocke) said : #5

?????I do not understand???
The Jython is available on the SikuliX Download Page.
Just follow the steps mentioned

Panos (zappas) said : #6

Thank you for the answer, now thats weird i download jython from the sikulix page n save it in the same folder with sikulix. This time Sikuli started without a warning msg but when i run a sikuli-script it does nothing -> sikuli closes* n the jython jar disappears...
* i check the processes n no sikuli or java process exists

RaiMan (raimund-hocke) said : #7

run as
java -jar sikulix.jar -v -c

and check the log
Might be a problem with your Linux.

BTW: the downloaded Jython jar is moved to the Sikulix extensions folder (as mentioned on the Download page!)

Panos (zappas) said : #8

Now we have log
 [error] RunTimeIDE: loadLib: opencv_java not usable:
java.lang.UnsatisfiedLinkError: no opencv_java in java.library.path
[error] RunTimeIDE: *** terminating: problem with native library: opencv_java
[debug] RunTimeIDE: final cleanup
[debug] FileManager: deleteFileOrFolder:
/tmp/Sikulix_569805985
[DEBUG] RunIDE: terminating: returned: 1

opencv 2.4 installed

RaiMan (raimund-hocke) said : #9

I think the docs are clear enough.
So please go back, read and understand:
https://sikulix-2014.readthedocs.io/en/latest/newslinux.html#version-1-1-4-special-for-linux-people

Panos (zappas) said : #10

i carefully read the doc..follow every step...(obviously the problem has to do with open_cv) i cmake 3.4+ open_cv n get the expected output -> run sikuli same result...then i try to link it same result... my final solution was... i download n setup sikuli 1.1.3 and it works fine... i cant say problem solved but bypassed. so yes we can close it
ty very much

Michael Liu (mtliu) said : #11

I have had this exact same thing happen. But it is on a windows 10 install. It doesn't happen on all machines, just a select few. Normally, just downloading the three files (IDE, jython, and api) works fine with 1.1.14.

However, a Dell machine with i7-8750H CPU doesn't work. Upon execution, the jython jar is deleted from the directory with the message can't find jython. Putting a copy of the jython back into the directory - then executing the IDE again, the jython file is deleted again, but no error message after the first execute. It's very puzzling. Tried resetting windows with fresh install on machine - then reinstalled java and no other apps, same thing. Only solution on that particular machine is to install 1.1.3. The 1.1.4 works fine on other machines with Ryzen CPU, 4th gen i5, and 3rd gen i7 cpu.

RaiMan (raimund-hocke) said : #12

What SikuliX does:
- looks for a jython...jar, jruby....jar in the folder having the siklix jars and if found: move to folder <appdata>/Extensions (this is why the jar vanishes)
- the Extensions folder is evaluated about available runner jars (jython, jruby) and other possible jars, to be put on the java classpath

This normally works.

The workaround is to move the jar directly to the Extensions folder.