[1.1.4] IDE: App.open("cmd ...") not working (only when run from commandline)

Asked by Tony May on 2018-09-09

I am using Java 8 and SikuliX 1.1.4 IDE. I have a test script that uses App.open to run a Windows batch script that launches a program. If I run the test script from the Windows command line it launches the tool from the batch script, however, if I run the same test script from the IDE, the tool is not launching. This works fine in both the IDE and the command line when using SikuliX 1.1.0

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-09-09
Last reply:
2018-09-10
Tony May (tonymay) said : #1

Windows 7

RaiMan (raimund-hocke) said : #2

ok, I have to check (... but on Windows 10, no Win 7 available).

RaiMan (raimund-hocke) said : #3

BTW: please post your App.open() statement.

Tony May (tonymay) said : #4

App.open("C:\\Sikuli\\LaunchViewX.bat")

Can you help with this problem?

Provide an answer of your own, or ask Tony May for more information if necessary.

To post a message you must log in.