Errors on startup Sikuli 1.1.3 and 1.1.4

Asked by Boudewijn Timmers on 2018-08-31

I get errors on starting 1.1.4, so tried 1.1.3 but same issue. Headline is this:
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/sikuli/ide/Sikulix : Unsupported major.minor version 52.0

I just installed Java JRE as required, and my mac is on osx 10.13.6

both doubleclicking the 1.1.4 version jar as well as java -jar sikulix.jar in Terminal do not work.

Any suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2018-08-31
Last query:
2018-08-31
Last reply:
2018-08-31
RaiMan (raimund-hocke) said : #1

as mentioned everywhere: must at least be Java 1.8, 10 and 11 are working also.

I suggest to stick with 1.1.4

Boudewijn Timmers (boudewijnt) said : #2

I have java 10.0.2 according to java.com/verify. So now what?

RaiMan (raimund-hocke) said : #3

in a Terminal run:
java -version

- which one is running?

Boudewijn Timmers (boudewijnt) said : #4

aha! 1.6.0_65
will have to find out how to upgrade the Runtime.

Best RaiMan (raimund-hocke) said : #5

on Mac currently the easiest way is to install a JDK instead.

This leads to that always the latest version is used.

The stuff is stored in
/Library/Java/JavaVirtualMachines

and can be managed in Terminal using
/usr/libexcec/java_home

Boudewijn Timmers (boudewijnt) said : #6

Thanks RaiMan, that solved my question.