version 1.1.4 does not run

Asked by Seyed Mohammad Hossein Amirkhalili on 2018-08-25

Version 1.1.4
Windows 10 64 bit

I just downloaded the newest version which does not need to setup. But when I click on it it takes few seconds the mouse pointer shows as if the pc is doing something in the background and then the mouse pointer turns back to normal and nothing happens.

I tried to run it also with the following command to get some logs and this is the output:

java -jar sikulix.jar -d 3 -c

C:\Sikuli>java -jar sikulix.jar -d 3 -c
[debug] RunTimeINIT: java version
[debug] RunTimeINIT: user.home
[debug] RunTimeINIT: user.dir
[debug] RunTimeINIT: app data path
[debug] RunTimeINIT: store debug.txt
[debug] RunTimeINIT: loadOptions: check: C:\Sikuli
[debug] RunTimeINIT: loadOptions: check: C:\Users\evstr
[debug] RunTimeINIT: loadOptions: check: C:\Users\evstr\AppData\Roaming\Sikulix\SikulixStore
[debug] RunTimeINIT: global init: entering as: IDE
[debug] RunTimeINIT: Accessing: GraphicsEnvironment.getLocalGraphicsEnvironment()
[debug] RunTimeINIT: Accessing: GraphicsEnvironment.getLocalGraphicsEnvironment().getScreenDevices()
[debug] RunTimeINIT: ScreenDevice 0 has (0,0) --- will be primary Screen(0)
[debug] RunTimeINIT: Monitor 0: (0, 0) 1920 x 1080
[debug] RunTimeINIT: runs as sikulix.jar in: C:\Sikuli
[43 debug] RunTimeINIT: exists libs folder at: C:\Users\evstr\AppData\Roaming\Sikulix\SikulixLibs
[46 debug] RunTimeINIT: libs folder empty or has wrong content
[47 debug] RunTimeINIT: export libs from: null
Exception in thread "main" java.lang.NullPointerException
        at org.sikuli.script.RunTime.libsExport(RunTime.java:894)
        at org.sikuli.script.RunTime.init(RunTime.java:695)
        at org.sikuli.script.RunTime.get(RunTime.java:375)
        at org.sikuli.ide.SikulixRunIDE.main(SikulixRunIDE.java:32)
[1022 debug] RunTimeINIT: final cleanup
[1031 debug] FileManager: deleteFileOrFolder:
C:\Users\evstr\AppData\Local\Temp\Sikulix_1392585549

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
masuo
Solved:
2018-08-26
Last query:
2018-08-26
Last reply:
2018-08-26

This question was originally filed as bug #1789025.

RaiMan (raimund-hocke) said : #1

should first be a question

Best masuo (masuo-ohara) said : #2

@Seyed Mohammad Hossein Amirkhalili
You are using Java 32bit.
Try Java 64bit.

RaiMan (raimund-hocke) said : #3

@masuo
Good idea, I have to check that 32-Bit Java is not accepted: MUST be 64-Bit Java

@Seyed Mohammad Hossein Amirkhalili
What Java version?

@RaiMan: My java version was 32bit.

I installed 64 bit Java version and viola it opened the IDE. @masuo thanks for the help :)

Thanks masuo, that solved my question.