[1.1.4]SikuliX IDE does not open without Extensions folder --- fixed

Asked by masuo on 2018-08-23

Download jython-standalone-2.7.1.jar and sikulix.jar, and move both files to a folder.
Doubleclick sikulix.jar, but nothing happened.

After move jython-standalone-2.7.1.jar to Extensions folder and doubleclick sikulix.jar, SikuliX IDE opened.
[Extensions folder]
C:\Users\username\AppData\Roaming\Sikulix\Extensions

[Environment]
OS: Windows10
Java: Java HotSpot(TM) 64-Bit Server VM (build 25.181-b13, mixed mode)
SikuliXIDE: 1.1.4(2018-08-22_10:10)

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2018-08-24
Last query:
2018-08-24
Last reply:
2018-08-23
Tim B (tangob) said : #1

To be fair, the download page does say:
-----------------
Needed for scripting support in the IDE and running scripts from commandline

The Jython interpreter 2.7.1 for python scripting (the default)
The JRuby interpreter 9.x for ruby scripting

Download what you prefer or both to the same folder as you have your sikulix.jar.
They will be recognized by SikuliX at the next start.
So preferably download before using the IDE the first time.
----------------

I also did not see this at first, and had the same result as you (loading the IDE .jar did nothing to start). If they are downloaded to the same folder, as indicated on the download page instructions, the IDE .jar actually copies them to the Extensions folder for you =)

masuo (masuo-ohara) said : #2

@Tim B
Between your environment and my one may be different .

RaiMan (raimund-hocke) said : #3

Hey people, thanks for being so fast ;-)

@Tim: absolutely right: jython and/or jruby are copied to extensions, whenever available at startup

@masuo: download the latest sikulix.jar and try again - it works as it should ;-)

There is a little gap currently: If you had scripts open, when you closed the IDE the last time (with 1.1.3 …). At startup 1.1.4 IDE now tries to open the scripts, what currently does not work, if jython is not there - so the IDE silently dies.

I will add a note about this behavior to the docs.

I am still working on the complete startup.

RaiMan (raimund-hocke) said : #4

@masuo
Has nothing to do with environment. It is just the version of your jar: 1 day behind ;-)

masuo (masuo-ohara) said : #5

@RaiMan
Please check the operation to copy Sikulix.jar to a PC which has not used SikuliX so far.
Sikulix folder does not exist at C:\Users\username\AppData\Roaming.
Does it work properly even in that case?

masuo (masuo-ohara) said : #6

@RaiMan
I changed title of this question.

Best RaiMan (raimund-hocke) said : #7

@masuo: yes, you are right - will fix that.

masuo (masuo-ohara) said : #8

Thanks RaiMan, that solved my question.

RaiMan (raimund-hocke) said : #9

@masuo
fixed with build 2018-08-24_07:19