Having trouble installing Sikuli on Ubuntu 18.04LTS

Asked by arminius on 2018-07-19

I googled around, tried "https://askubuntu.com/questions/223429/how-can-i-get-sikuli-ide-to-work"

    user@Computer:~$ sikuli-ide
    sikuli-ide: command not found

Tried a few other things, they might all be for an older version of Ubuntu, can anyone point me to the current best guide?

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-07-19
Last reply:
2018-08-02
RaiMan (raimund-hocke) said : #1

http://sikulix-2014.readthedocs.io/en/latest/basicinfo.html#sikulix-on-linux

... but be prepared to get a version of OpeneCV 2.4

arminius (arminius75) said : #2

when I right click on the Jar file, it comes up with open with Open JDK Java 11 runtime, I click on that, and nothing happens.
It's been set to be an executable.

RaiMan (raimund-hocke) said : #3

Java 11?

Will only be available officially in September?

You should use Java 8 (LTS) or Java 10

arminius (arminius75) said : #4

so I followed these instructions "https://tecadmin.net/install-oracle-java-8-ubuntu-via-ppa/"
and now when I right click on the jar file it says open with oracle java 8 runtime
but alas nothing happens.
Maybe I should open a thread on the Ubuntu forum.

RaiMan (raimund-hocke) said : #5

recommended: use 1.1.3 nightly and follow the instructions on
http://sikulix.com -> Nightly Builds

TestMechanic (ndinev) said : #6

I was able to compile steps for configuring required modules for sikuli 1.1.2 on Ubuntu18/Lubuntu18

https://drive.google.com/open?id=1K4Yvq3jSSNpyvixegUMAsyp_bNluYfXOo3peTIQ8Rig

Can you help with this problem?

Provide an answer of your own, or ask arminius for more information if necessary.

To post a message you must log in.