Run sikuli for linux with another version of opencv?

Asked by MPE on 2018-07-09

In the installation instructions for running Sikuli on Linux, it is specifically stated that you should have opencv 2.4 and tesseract 3.

Recently however, I have been planning a switch from Linux Mint 18.3 (which uses both packages in its repo) to Linux Mint 19 (which has newer versions, 3.2 and 4 respectively).

Since Sikuli is an important application to me, I would like to know if it is possible to run Sikuli (in any kind of "workable" way (for a normal non-geek user like myself)) with these newer versions.

Question information

Language:
English Edit question
Status:
Answered
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-07-09
Last reply:
2018-07-09
RaiMan (raimund-hocke) said : #1

If there is no easy way, to use the OpenCV 2.4 packages from 18.3 in 19, then there is no easy solution for you.

But I have to admit:
Since I did not reach my own objectives with SikuliX version 2 (will not be available before 2019, uses OpenCV 3.x), I think I have to backport the version 2 image search implementation solution to a 1.1.4.

I will start to do that during the next days. But it will take some weeks.

I will make a request bug of that, which will keep you informed.

Can you help with this problem?

Provide an answer of your own, or ask MPE for more information if necessary.

To post a message you must log in.