Eclipse dialogs appear blank for sikuli in Ubuntu (taking image or searching)

Asked by Tzvi on 2018-07-01

As stated in the title, when trying to capture the UI of a modal dialog (I.E New Project, Preferences etc..) the UI of the dialog appears totally blank, only the title bar is visible with the title of the current dialog.

Whats more, in Windows there is no such issue.

Tried with Oxygen3a, Photon editions, same result.

Seems like the dialogs are not being on top level, but the question is what's causing it, is the Sikuli, the OS, or eclipse's behavior under ubuntu?

and how can i overcome this (except using offset from the titlebar).

Whats interesting also is if i move the dialog to intersect with the taskbar on the left of Ubutnu's UI, then the dialog is visible to sikuli!

Regards.

Question information

Language:
English Edit question
Status:
Solved
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Solved by:
RaiMan
Solved:
2018-07-01
Last query:
2018-07-01
Last reply:
2018-07-01
Best RaiMan (raimund-hocke) said : #1

I am sorry for the inconvenience, but I cannot help you with that.

The problem is, that the Ubuntu desktop manager Unity seems to be implemented in a way, that in parts is not compatible with the capture feature of SikuliX based on the Java AWT Robot class.

You might try with a different desktop manager.

Tzvi (mr-gears) said : #2

Thanks RaiMan, that solved my question.