Error in setting up Sikuli In Ubuntu

Asked by Srikanth Muralidharan on 2018-06-22

[debug (6/22/18 6:50:37 PM)] RunSetup: checking usability of bundled, provided or built libs
[debug (6/22/18 6:50:37 PM)] RunTimeSETUP: exists libs folder at: /root/.Sikulix/SikulixLibs_201803080837
[error (6/22/18 6:50:37 PM)] RunTimeSETUP: loadLib: libVisionProxy.so not usable:
java.lang.UnsatisfiedLinkError: /root/.Sikulix/SikulixLibs_201803080837/libVisionProxy.so: libopencv_core.so.2.4: cannot open shared object file: No such file or directory
[error (6/22/18 6:50:37 PM)] RunTimeSETUP: loadLib: libVisionProxy.so not usable:
java.lang.UnsatisfiedLinkError: /root/.Sikulix/SikulixLibs_201803080837/libVisionProxy.so: libopencv_core.so.2.4: cannot open shared object file: No such file or directory
[debug (6/22/18 6:50:37 PM)] LinuxSupport: we have to build libVisionProxy.so
[debug (6/22/18 6:50:37 PM)] LinuxSupport: checking: availability of OpenCV and Tesseract
[debug (6/22/18 6:50:37 PM)] LinuxSupport: checking: scanning loader cache (ldconfig -p)
[debug (6/22/18 6:50:37 PM)] RunTimeSETUP: ldconfig -p
[error (6/22/18 6:50:37 PM)] LinuxSupport: checking: OpenCV not in loader cache (see doc-note on OpenCV)
[error (6/22/18 6:50:37 PM)] LinuxSupport: checking: Tesseract not in loader cache (see doc-note on Tesseract)
[error (6/22/18 6:50:37 PM)] RunTimeSETUP: Problematic lib: /root/.Sikulix/SikulixLibs_201803080837/libVisionProxy.so (...TEMP...)
[error (6/22/18 6:50:37 PM)] RunTimeSETUP: libVisionProxy.so loaded, but it might be a problem with needed dependent libraries
ERROR: ...TEMP...: libopencv_core.so.2.4: cannot open shared object file: No such file or directory
[error (6/22/18 6:50:37 PM)] RunSetup: libVisionproxy.so finally not useable
[error (6/22/18 6:50:37 PM)] RunSetup: Giving up!
[error (6/22/18 6:50:37 PM)] RunSetup: ... terminated abnormally :-(
[debug (6/22/18 6:50:37 PM)] RunSetup:
popError: --------------------
Something serious happened! Sikuli not useable!
Check the error log at /home/ubuntu/Downloads/SikuliX-1.1.2-SetupLog.txt

Question information

Language:
English Edit question
Status:
Expired
For:
Sikuli Edit question
Assignee:
No assignee Edit question
Last query:
2018-06-22
Last reply:
2018-07-14

Please help ASAP

TestMechanic (ndinev) said : #2

What version of Ubuntu?

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.